Preface

The concept of an **Aggregated Scale Morphological Interaction between Tidal basin and Adjacent coast** (ASMITA) was first proposed by Marcel Stive and co-workers at TU Delft. The first Matlab version of ASMITA was developed by Tjerk Zitman at TU Delft. Work by Zheng Bing Wang and colleagues also at TU Delft further developed the model and set out the basis of model parameterisation. As part of the Estuaries Research Program Phase 2 (ERP2), funded by the Environment Agency and Department for Environment, Food and Rural Affairs (part of project FD2107) this research code was documented, tested and a manual prepared by Ian Townend and Adrian Wright at ABPmer. Version 1.3 was released as Open Source software available from the Estuary Guide web site ([www.estuary-guide.net](http://www.estuary-guide.net)). Further developments were undertaken to add additional elements and processes by Ian Townend, Jeremy Spearman, Kate Rossington and Michiel Knappen at HR Wallingford. This manual details a new version that has an Object Oriented design and was developed by Ian Townend at CoastalSEA in 2016.

Requirements

The code is written in Matlab™ and provided as Open Source code (issued under a GNU General Public License). Routing within the model makes use of graph and directed graph functions which were introduced in Matlab 2015b. There are however several versions of these functions available from the Mathworks File Exchange if there is a need to use an earlier version of Matlab™.

Resources

The zip file contains the following:

Matlab code and supporting files, sample models, and user manual.

Bibliography

Key papers setting out the theoretical background to the model include:


Further sources of information are detailed in the References towards the end of the Manual.
Contents

1 Introduction .................................................................................................................. 1
2 Getting Started ........................................................................................................... 2
  2.1 ASMITA OO software ......................................................................................... 2
  2.2 Opening ASMITA ............................................................................................. 2
  2.3 Typical workflow to set-up new model .............................................................. 2
  2.4 Parameter settings for sample models ............................................................... 5
3 Menus ......................................................................................................................... 10
  3.1 File ....................................................................................................................... 10
  3.2 Tools .................................................................................................................... 10
  3.3 Project ................................................................................................................. 11
  3.4 Setup ................................................................................................................... 11
  3.5 Run ....................................................................................................................... 16
  3.6 Plot ...................................................................................................................... 16
4 Supporting Information for Model Setup ................................................................. 17
  4.1 Model elements ................................................................................................. 17
  4.2 Dispersion .......................................................................................................... 19
  4.3 Advection ............................................................................................................ 20
  4.4 Interventions ....................................................................................................... 20
  4.5 Saltmarsh ............................................................................................................ 21
  4.6 Storage ................................................................................................................ 22
5 User functions ........................................................................................................... 22
  5.1 AsmitaModel ....................................................................................................... 22
  5.2 UserPrismCoeffs ............................................................................................... 22
  5.3 UserSLRrate ....................................................................................................... 23
  5.4 UserUnitTesting ................................................................................................. 23
6 Program Structure ..................................................................................................... 23
7 Additional References ................................................................................................. 24
   Appendix A – Function call sequence in RunModel ............................................... 26
   Appendix B – UML Class diagrams ....................................................................... 28

ASMITA OO manual
Version 1.3, September 2016
1 Introduction

Aggregated Scale Morphological Interaction between a Tidal inlet and the Adjacent coast (ASMITA).

This manual has been written as a guide to using the Matlab ASMITA model and illustrates the concepts and methodology used in long-term morphological modelling.

The idea behind ASMITA is that a tidal basin, or estuary can be sub-dividing into a number of elements (Figure 1). Each element has an equilibrium condition when unperturbed and following some form of perturbation (eg. sea level rise, addition or removal of volume or area) the model seeks a new equilibrium. For example, if under initial conditions the accommodation space is zero (no net change in the transport of sediment), with increased mean sea level the accommodation space becomes positive and sediment may be imported, the opposite is true when sea level falls.

The key concepts of the ASMITA model are:

- The estuary is schematized into a number of geomorphologic elements;
- The state of each element is described by its volume and plan area (water or sediment);
- Integrated parameters of hydrodynamics (tidal prism, or tidal range) are used;
- Empirical relationships define the morphological equilibrium for each element;
- Deviation from the morphological equilibrium causes sediment demand; and
- A gradient in sediment demand drives sediment transport, and thereby morphological change.

The theoretical background to the model is explained in various published papers as detailed in the Bibliography in the Preface and in the References.
2 Getting Started

2.1 ASMITA OO software
The ASMITA software has been written using the software language Matlab, version 2015/16. The software utilises only core Matlab functions and does not use any toolboxes. Section 6 of this manual provides details of the program structure, including the class diagram, function call and related information that will be of use to those who wish to develop the software, or explore alternative model parameterisations. To support this, a number of functions have been written as standalone (i.e. not contained within the class code file) to allow the user to modify aspects of the model behaviour. These are detailed in Section 5.

2.2 Opening ASMITA
A graphical user interface (GUI) is used to set-up, run scenarios, plot results and export model output. With the Matlab working directory (folder) pointing to the folder containing the ASMITA code, the GUI is run from the command prompt by typing:
>> Asmita.Gui;
A splash screen crediting the developers appears for a few seconds before being replaced by the ASMITA interface (Figure 2).

Figure 2 - The ASMITA GUI

2.3 Typical workflow to set-up new model
The following steps explain how to set-up a model using the various tools provided. Text in Red italic refers to drop down menus. Text in Green italic refers to Tab titles.

File>New: define project name and date
Setup>Estuary>System Properties: define equilibrium concentration
Setup>Estuary> Water Levels: define tidal range, slr and any variation in tidal range (e.g nodal tide)
Setup>Element>Define Elements: specify how many elements of each type are needed
Setup>Element>Element Properties: define volume, area etc for each element
Setup>Run Parameters>Time Step: define time step and length of run
Setup>Run Parameters>Equilibrium Coefficients: select equilibrium prism coefficient set from list (coefficients are defined in UserPrismCoeffs.m – see Section 5.2 for further details).
Setup>Estuary>Dispersion: define the horizontal exchange between elements. The direction from-to working landwards from the most seaward element is important as this is used to calculate the tidal prism in each reach.

River flow, Interventions, Littoral Drift, Saltmarsh, Tidal Pumping and various constraints can be added as required. However, the above is the minimum required for the model to run.

To examine what has been set-up the Tabs provide a summary of what is currently defined. Note: these only update when clicked on using a mouse and the values cannot be edited from the Tabs.

Scenarios: lists the cases that have been run with a case id and description.
System: tabulates the system properties and flags that have been set (display only).
Elements: tabulates the key properties of each element (display only).
Run Props: tabulates the key run conditions and equilibrium coefficients (display only).
Network: graphic of the element network showing the connectivity and horizontal exchanges between all elements (m³/s).
Flows: graphic of the elements that have an advection (e.g. channels) showing the connectivity and the flow rate (m³/s).
Response: summary of morphological response times based on system definition.
Help: an abridged version of this workflow guide.
Adding a river flow:

Setup>River: define channel element that river flows into, flow rate and sediment concentration

Setup>Estuary>Advection: define how the river flows through the model. Again this is specified as from-to and the total flow into any element must equal the flow out.

Setup>Run Parameters>Conditions: check the flag for River flow offset, if you want the flow to be accounted for in the initial condition.

Note: river flows can also be added and edited in the Advection definition table but this still requires the concentration of any sediment load to defined using the Setup>River user interface.

Adding interventions:

Setup>Interventions: select element and define the years in which there is a change. Positive is an increase in water volume or surface area.

Setup>Run Parameters>Conditions: check flag to include interventions. (Note that once interventions have been defined, they can be included or omitted by using this flag).

To run the model:

Run>Check input: Checks that what components have been set-up and lists those that have not been set-up (Figure 4).

Run>Run model: Runs setup check and then runs model. If not enough components are defined a warning dialogue is shown and the run aborted. If the model runs the user is prompted for a description of the scenario (model run).

If the time step specified is likely to be unstable the user is prompted with a suggested time step and the number of steps to simulate the same period of time. The user can select this alternative, use the value specified in the model setup or abort the run.

To plot the results:

Plot>Plot menu: launches the plotting GUI. Using the Time Tab, Scenarios can be selected and the results for any (or All) elements can be plotted for each variable (volumes, prism, water levels, concentration, etc).

Other Tabs are shown but are not yet functional.

To write the results to an Excel file:

Project>Scenarios>Save: list dialogue allows user to select which scenario is to be written to file (only a single scenario can be selected at a time). A user input dialogue then prompts for a file name (no extension required). The Excel file contains the run parameters on the Readme worksheet followed by a worksheet for each variable (titled by short variable symbol - e.g. vm for moving surface volume) with the year in column 1 and the results for each element in the subsequent columns.
2.4 Parameter settings for sample models
The zip file includes some sample models as *.mat files. The parameters needed to run the models are saved in these files (along with any scenarios that have been run).

2.4.1 Humber Model (simple 3 element model: delta-channel-flat)
The settings used in the Humber3EM model are as follows:

- **Setup>Estuary>System Properties**: Coarse Fraction Equilibrium Concentration = 0.72 kg/m$^3$. Fine fraction value is the same in this example (see Section 2.4.3 for details of how to introduce mixed sediments).

- **Setup>Estuary> Water Levels>Tidal Range** = 5.84 m (at mouth)

- **Setup>Estuary> Water Levels>LW/HW amplitude ratio** = 1 if the tidal signal (or related cycles) is not symmetric about mean tide level, this ratio allows an adjustment to be made (the default is 1).

- **Setup>Estuary> Water Levels>Mean Sea Level at t=0** = 0 m. Allows for any offset of MSL to the local datum used for elevations.

- **Setup>Estuary> Water Levels>Rate of sea level rise** = 0.0018 m/year

- **Setup>Estuary> Water Levels>Number of Cycles** = 2

The next three fields can have multiple values to include the number of cycles specified

- **Setup>Estuary> Water Levels>Amplitude** = 0.1 0.04 m

- **Setup>Estuary> Water Levels>Period** = 18.6 180 years.

- **Setup>Estuary> Water Levels>Phase** = 12.2 128 years. Defines the offset to give the correct timing of each cycle in the Julian calendar.

- **Setup>Element>Define Elements**: specify how many elements of each type are needed. A table then lists all elements and the user can amend the Type of element, the name given to the element and whether it is erodible or not.

The elements and then created and the properties for each element must all be defined as follows:

- **Setup>Element>Element Properties**: select element and define properties. The following table details the properties used in the 3 element Humber model:

<table>
<thead>
<tr>
<th></th>
<th>Channel</th>
<th>Tidal Flat</th>
<th>Delta</th>
</tr>
</thead>
<tbody>
<tr>
<td>Initial volume (m$^3$)</td>
<td>1.079e9</td>
<td>3.97e8</td>
<td>7.719e8</td>
</tr>
<tr>
<td>Initial plan area (m$^2$)</td>
<td>1.867e8</td>
<td>9.85e7</td>
<td>5.0e7</td>
</tr>
<tr>
<td>Length (m)</td>
<td>1.34e5</td>
<td>1.34e5</td>
<td>1.0e4</td>
</tr>
<tr>
<td>Vertical exchange (m/s)</td>
<td>0.003</td>
<td>0.003</td>
<td>0.003</td>
</tr>
<tr>
<td>Transport coefficient (-)</td>
<td>2</td>
<td>2</td>
<td>-2</td>
</tr>
<tr>
<td>Bed density (kb/m$^3$)</td>
<td>1350</td>
<td>1350</td>
<td>1350</td>
</tr>
<tr>
<td>Sediment mobility</td>
<td>1</td>
<td>1</td>
<td>1</td>
</tr>
</tbody>
</table>

Notes:
- Volumes are between the upper and lower surface of the element eg low water and bed for channel elements and high water and low water for tidal flat elements
- Plan areas are measured on the upper surface. For Tidal flats this is the area over the flat at high water and does not include the area of the channel.
- Length is the along channel length of the element
- Vertical exchange and Transport coefficient are determined as explained in Townend et al (2016). The Transport coefficient for the Delta is negative because the equilibrium condition of this type of element is in terms of sediment volume whereas the others are all in terms of water volume.
- Bed density is a representative density for the bed in each element.
- Sediment mobility is only used when tidal pumping is included to adjust the along channel concentrations.

Setup>Run Parameters>Time Step>Time Step = 0.5 (years)
Setup>Run Parameters>Time Step>Number of Time Steps = 640 (i.e. 320 years)
Setup>Run Parameters>Time Step>Output Interval = 2 (i.e. every other time step)
Setup>Run Parameters>Time Step>Start Year = 1703 (default is zero and only needed if doing a historical hindcast. However, any Interventions must be defined relative to the same time frame)
Setup>Run Parameters>Equilibrium Coefficients: select ‘Default’
Setup>Estuary>Dispersion: define the horizontal exchange between elements. A row element defines the ‘supply’ and the column element defines the ‘receptor’ for a flooding tide to define a landward flow path from the most seaward element(s), Figure 6. This is used to define the structure of the element network and to calculate the tidal prism in each reach.

Figure 6 – Add horizontal exchange rates using the Dispersion table UI

A convenient way to check the Dispersion set-up is to use the Network tab to plot the tidal network from Outside (sea) to the most landward elements (including any branches)

Setup>Run Parameters>Conditions: check flag to ‘Scale to initial values’.
This is sufficient information for the model to run.

Adding a river flow:

Setup>River: define channel element that river flows into, flow rate and sediment concentration, Figure 7.

Setup>Estuary>Advection: define how the river flows through the model. Again this is specified as from row element - to column element and the total flow into any element must equal the flow out, Figure 8.
Add advection flow rates using the Advection Table UI

A convenient way to check the Advection set-up is to use the Flow tab to plot the flow network from Source (river or rivers) to Outside (sea).

Setup>Run Parameters>Conditions: check the flag for ‘River flow offset’, if you want the flow to be accounted for in the initial condition.

Adding interventions:

Setup>Interventions: select element from list table and use the table UI to define the years in which there is a change, Figure 9. Positive is an increase in water volume or surface area.

Setup>Run Parameters>Conditions: check flag to include interventions, Figure 10. (Note that once interventions have been defined, they can be included or omitted from an individual model by using this flag, but remain saved in the model set-up).

Figure 10 – Conditions UI allows conditions and constraints to be included or omitted from model run.
2.4.2 Venice model (multiple inlets and saltmarsh)

The steps to setup the model follows those outlined above. The main differences here are the addition of multiple inlets which are defined using the Dispersion and Advection parameters and the inclusion of saltmarsh. The following summarises the settings used in the Venice 9EM model and details the additional steps to setup the model.

Setup>Estuary>System Properties: Coarse Fraction Equilibrium Concentration = 0.04 kg/m$^3$.

Setup>Estuary> Water Levels>Rate of sea level rise = 0.0014 m/year

The element properties and connectivity are as detailed in Figure 11 and Figure 12 respectively.

Setup>Tidal Constituents>M2 amplitude = 0.242 m.

Setup>Tidal Constituents>S2 amplitude = 0.143 m.
**Setup>Species Parameters**

The user interface to enter the saltmarsh parameters allows the user to enter multiple species values with values separated by a space as illustrated in Figure 13 (applies to minimum depth, maximum depth, Maximum biomass and Species productivity). Further explanation of the saltmarsh parameters is given in Section 4.5.

Note: edge erosion is only applicable when using variable surface areas
Not available in version 1.3

**Setup>Run Parameters>Conditions**: check the flag to ‘Include saltmarsh biomass’. If the flag is not checked, the model treats the saltmarsh element like any other element and uses the prism based relationship to define the equilibrium volumes (see Section 5.2).

**Setup>Run Parameters>Equilibrium Coefficients**: select ‘Venice’.

### 2.4.3 Amelander model (mixed sediments)

This model is used to explore the influence of introducing variable bed density and mixed (fine and coarse sediments. The original model was detailed in van Goor et al. (2003). This model was revisited to consider the influence of fine sediment in Wang et al. (2014) and extended to consider the combined influence of mixed sediment and bed density in Townend et al. (2016b). The file provided has the parameters setup for case (vi) in Table 2 of Townend et al. and the various cases listed in Table 2 have already been run and saved in the model.

**Setup>Estuary>System Properties: Coarse Fraction Equilibrium Concentration** = 0.64 kg/m³.

**Setup>Estuary>System Properties: Fine Fraction Equilibrium Concentration** = 0.2 kg/m³.

The element properties and connectivity are as detailed in Figure 14. The dispersions are simply 300, 300, 10,000 as the exchanges from Outside to Delta, Delta to Channel and Channel to Tidalflat respectively.
2.4.4 Severn model (tidal pumping)

This model illustrates the inclusion of tidal pumping. The set up procedure is similar to that used for the Humber (Section 2.4.1). The only addition is to set the condition to include tidal pumping. For this this to be meaningful, the channel needs to be sub-divided into a number of elements (6 are used in this case). The model also shows the use of multiple tidal flats linked to each channel reach (one for each side of the estuary). This can be useful for illustrating change but the dynamics of the model are the same if a single tidal flat is used for each reach (assuming the properties are the same for each pair of flats). This model also allows the plotting of variations along the channel using the Distance and XYZ tabs in the plot GUI, as illustrated in Figure 15.

Figure 15 – Plots from Severn model showing along channel variation at a point in time and as space-time surface

3 Menus

3.1 File

File> New: clears any existing model (prompting to save if not already saved) and a popup dialog box prompts for Project name and Date (default is current date).

File> Open: existing Asmita models are saved as *.mat files. User selects a model from dialog box.

File> Save: save a file that has already been saved.

File> Save as: save a file with a new or different name.

File> Exit: exit the program. The close window button has the same effect.

3.2 Tools

Tools> Refresh: updates Scenarios tab.

Tools> Clear all> Model: deletes the current model.

Tools> Clear all> Figures: deletes all results plot figures (useful if a large number of plots have been produced).

Tools> Clear all> Scenarios: deletes all scenarios listed on the Scenarios tab but does not affect the model setup.
3.3 Project

*Project>Definition:* edit the Project name and Date

*Project>Scenarios>Edit:* table listing of scenario descriptions allowing the user to edit individual descriptions.

*Project>Scenarios>Save:* user selects the scenario to be saved from a list box of scenarios and the is then prompted to name the file. The full details of the model setup and the results are written to an Excel spreadsheet.

*Project>Scenarios>Delete:* user selects the scenario to be deleted from a list box of scenarios and results are then deleted (model setup is not changed).

3.4 Setup

The setup menu provides a series of menus to enable different components of the model to be defined.

**Setup>Estuary>System Properties:**

- Define the concentration that is target or global equilibrium concentration. These should be the same value if only a single fraction is being considered.
- The e-folding length is the rate of width convergence and is used if tidal pumping is included.
- Wind speed and the elevation at which the wind is measured are used in the 3D estuary form model to account for internal wave action (not implemented in version 1.3).

**Setup>Estuary>Water Levels:**

- Tidal range and period are defined at the entrance to estuary, or inlet.
- The LW/HW amplitude ratio accounts for any difference in the amplitude to low water and high water relative to the define mean sea level\(^1\). Used to adjust influence of changes in tidal range.
- The mean sea level at the start of the model run (allows for offsets from zero datum).
- Rate of sea level rise as a linear rate (positive or negative). See Section 5.3 for alternatives.
- Number of cycles to be included that vary the tidal range as a function of time. The number of entries for amplitude, period and phase have to agree with the number of cycles specified. The phase defines a shift in the cycle to align with the Julian calendar. This is only or relevance if the model is being used to hindcast change and compare volume changes with observed changes (e.g. Townend et al., 2007).

---

\(^1\) Option included because of observed bias (e.g. on Humber nodal tidal cycle has an amplitude of 0.23m with a high water amplitude of ~0.14 and low water amplitude of ~0.08; i.e. ratio = 0.08/0.14 = 0.57). The default value is 1.
Setup>Estuary>Dispersion:

Define the horizontal exchange between elements (m/s). Exchanges proceed from the most seaward element(s) in a landwards direction. Values are entered in the cell which is from a row element going to a column element (e.g. from row Delta to column Channel). These are used to determine the network connectivity and the resultant network can be viewed on the Network tab. For detail of how to estimate appropriate values for the horizontal exchange see Wang et al. (2008) or Townend et al. (2016a).

Setup>Rivers>River advection:

Define the advective flows through the channel network (m$^3$/s). For river flows, these are defined from the River source to the Outside (the open coast). Values are entered in the cell which is from a row element going to a column element (e.g. from Delta to Outside). There should be a mass balance in and out of any element and along the flow path(s) from Source(s) to the Outside. This is checked when the channel flow network is viewed on the Flow tab.

The sediment concentrations associated with the river inputs are defined in Setup>Rivers>River inputs. If a new river flow is added in the Advection table, a River object is added and the user is prompted to use the Setup>Rivers>River inputs component to add the sediment concentration.

A river input with a sediment load that is not equal to the coarse grain equilibrium concentration will act as a perturbation to the model (a forced change). To avoid this there is an option to include the advective flows in the Setup>Run Parameters>Conditions: by setting the ‘River flow offset’ check box. The details of this are explained in discussion on advective flows in Townend et al. (2016a).

Setup>Drift>Drift advection:

The same procedure is followed to include drift in and out of elements. The drift is specified for each linkage as littoral drift (i.e. a volume of sediment per year – m$^3$/year). There is an option, similar to the river setup to edit inputs to the system (Setup>Drift>Drift inputs).

However, there is no need to specify a concentration and so drifts can be set up by just using the advection table.

Setup>Estuary>Model Constants:

A number of constants are used in the model. Generally, the default values are appropriate but these can be adjusted and saved with the project if required.
**Setup>Element>Define Elements:**

When setting up a new model a listing of the different types of element allows the user to define the number of each type element to include in the model (elements can subsequently be added or deleted). Once a set of elements have been defined the user is prompted to edit the default names for each element, change the element type and choose to make the element non-erodible (for cases where the element can infill with sediment but if cannot erode.

After the initial setup, the user is taken straight to the Element Names dialog to edit the available list of elements. To add or delete elements use the dialogs from the main menu **Setup>Element>Add** and **Setup>Element>Delete**.

The definition of the Types of element currently available are given in Section 4.1.

**Setup>Element>Element Properties:**

Definition of elements is on a continuous loop. Select Cancel from the element list box to finish defining element properties.

Volume and surface area are defined for each element. The length is the distance along the flow axis (usually from seaward limit to landward limit).

The vertical exchange (m/s) is similar to a fall velocity.

The transport coefficient represents the scaling of the dominant mode of transport (i.e. velocity to some power)\(^2\). Note where sediment volumes are being used instead of water volumes the value should be **negative**.

The basis for setting the Vertical exchange and the Transport coefficient is discussed in Wang *et al.* (2008) or Townend *et al.* (2016a).

The wet or bulk density of the bed of the element.

The sediment mobility is only relevant if tidal pumping is included and is used to adjust the relative influence of elements in the along estuary channel concentration gradient.

**Setup>Element>Add**: select element type from list. The Define Element dialog box is then displayed allowing the user to edit the element name and whether it is erodible or not. Element properties and any Dispersion or Advection then need to be added using the individual dialog boxes for these components.

**Setup>Element>Delete**: select element to be deleted from the list of model elements.

---

\(^2\) If over the long-term the model is considered to represent a diffusion process, this would have a value of 2. Where advective transport (such as fluvial import dominates) then a value of 5 based on suspended load transport may be more representative or a value of 3 where bed load transport dominates sediment exchanges.
Setup> Saltmarsh> Species parameters:

Any number of saltmarsh species can be entered and a check is made to ensure that the number of values entered for minimum depth, maximum depth maximum biomass and species productivity is consistent with the number of species specified.

Coefficients for biomass dependent enhanced settling rate

Minimum and maximum marsh edge erosion rates due to wave action. These are only used when variable surface area is included. Not available in version 1.3.

Setup> Saltmarsh> Equilibrium marsh depth:

This utility allows the user to explore the response of the marsh depth to the defined saltmarsh parameters and to see how this response varies by adjusting the biomass production rates for each of the species included. On selecting this option, a dialog box presents the currently defined values of the biomass production rates and the user has the option to change these. [This does not alter the values saved in the model.] Three plots are then presented in a single figure. These show the average concentration the proportion of time submerged for the intertidal flat as a whole (top left) and the marsh surface (bottom left). The plot to the right then shows how the equilibrium depth and the equilibrium production of the marsh vary as a function of sea level rise. The dashed lines highlight the values for the rate of sea level rise defined in the model. For further discussion of the saltmarsh model and the bio-morphological response, see Townend et al. (2010).
Setup>Rivers>River inputs: This component can only be added once some channel elements have been setup in the model. If no rivers are defined, the dialog box requires the Channel id number, along with the flow rate and the concentration density of the rivers sediment load. If one or more rivers have already been added, a list box prompts the user to select from a list of channels with river inputs or to Add a river.

To remove an input, use Setup>Rivers>Delete input and select the source to be deleted from the list of channels with river inputs.

River flows can also be defined in the Setup>Rivers>River advection table but it is still necessary to add the Sediment concentration using the Setup>Rivers>River inputs dialog box.

Once Advection throughout the network has been defined the flow routes can be checked using the Flow tab.

Setup>Littoral Drift: Littoral drift is much the same way as river flows, except that a mass balance is not imposed. The source or inputs of drift can be defined as a drift rate (m3/year) using Setup>Littoral Drift>Drift inputs. However, there is no need to assign a concentration to the drift. The flow through the system is then defined using the advection table Setup>Littoral Drift>Drift advection, in the same way as for river flows. Drift inputs can be removed using Setup>Littoral Drift>Delete input.

Setup>Tidal Constituents:

Selected tidal constituents may be needed for certain model components. The model currently assumes a semi-diurnal tide and the M2 and S2 amplitudes are used to estimate the concentration over the marsh and the submergence time if Saltmarshes are included in the model.

The M4 amplitude and phase are used to estimate the influence of the over-tide in the tidal pumping component.

Setup>Interventions>: select element from list of elements and then use table to add interventions. Selection of elements is in a continuous loop. Select Cancel from the element list box to finish adding interventions. Define the Year of the intervention (this must be consistent with the Start Year and duration of the model run defined in Setup>Run Parameters>Time step). The Volume and Surface Area are the changes in water volume and element plan area respectively. Use negative values to represent reductions (e.g. due to a reclamation).
In order for the defined interventions to be included in the model run the Include Interventions condition needs to be set. This allows runs to be made with and without the interventions, without the need to redefine them each time.

**Setup>Run Parameters>Conditions:** check the flag to ‘Include Interventions’.

**Setup>Run Parameters>Time step:**

The time step parameters comprise the time step (years or parts of a year), the number of time steps and the intervals at which the model output should be saved. The product of time step and number of steps gives the run duration. The Start Year is relevant where and time dependent components are included that have used Years defined in the Julian calendar. If the results display erratic or chaotic behaviour, try reducing the length of the time step. There is an internal check stability check but this does not cover all situations.

Note: a check is made at the start of a model run and the user is warned if the time step is too long and given the option to use the value suggested by the stability check, to use the value specified in the model setup, or to abort the run. However, instabilities may still occur, especially when there is a large difference in the size of elements that make up the system. In such cases it is worth experimenting with shorter time steps to see if this removes or reduces the instabilities.

**Setup>Run Parameters>Conditions:**

A number of components can be defined in the model setup and the user can then select whether or not to include them in a particular model run. The details of the conditions included in a particular run are saved with each run scenario and can be recovered by saving the scenario where they are recorded on the Readme worksheet (*Project>Scenarios>Save*). Note: Bank erosion constraints only relevant if using variable surface area. Not included in version 1.3

### 3.5 Run

**Run> Check input:** checks mass balance of any advection flows included and that sufficient components have been defined for the model to run. This is not a full diagnostic check, so it does not ensure that the model output is valid – simply that the model will run.

**Run> Run model:** runs model, prompts for scenarios description which is added to the listing on the Scenarios tab.

### 3.6 Plot

**Plot>Plot menu:** initialises the Plot gui to select variables and produce various types of plot. The user selects the Scenario, Model element (or All elements), the Variable to used and the Scaling option from a series of drop down lists, Figure 16. There are then buttons to create a New figure or Add or Delete variables from an existing figure.
The Distance and XYZ tabs are only meaningful when the model being used has several channel elements, such that there is an along-channel subdivision that provides a measure of variations with distance from the mouth. These options use all elements and plot values representative of each channel reach as a function of distance (and time in the case of the XYZ tab). The types of output that these options produce are shown in Figure 15.

4 Supporting Information for Model Setup
4.1 Model elements

Decide how the estuary or tidal inlet should be sub-divided. This will usually involve a number of channel elements with associated tidal flat elements. In addition, there may be a need to include a tidal delta and any tidal flats associated with the delta. As far as possible it is worth trying to examine the constraints on the system (geology, sediment sources, sea walls, etc), as a basis for identifying “reaches” that are likely to have a consistent internal behaviour. It is also better to avoid very large differences in the size of elements (several orders of magnitude), as this can give problems in some of the matrix calculations.

Sometimes it is useful to set up a whole estuary model (comprising just a channel and tidal flats, or delta, channel and tidal flats) to get a feel for the overall behaviour of the system, prior to developing a more detailed representation. However, if river inflows with a sediment load are to be included, it should be noted that the response of a “single” channel element model, will be different to a multi-element model. As a consequence, it is sometimes better to ignore the river inflows for the single channel element case.

The Element types currently available include:

- **Channel**
  - Water volume below MLW and area at MLW.
  - *Can be linked to Outside, delta, tidalflat, storage and other channel elements.*

- **Delta**
  - Sediment volume of the delta (where the delta has a volume relative to the undisturbed coastal bed). A **negative** value of Transport coefficient should be defined in **Setup>Element>Element Properties**. Can also use this element type to represent delta flats.
  - *Can be linked to channel, Outside and other delta elements.*
<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tidalflat</td>
<td>Water volume between MLW and MHW over flats (i.e. not including the prism over the channel) and area over flats. Flats on both sides of channel in a given reach can be included in a single flat element. This element can also be defined as a sediment volume by defining a negative value of Transport coefficient in Setup&gt;Element&gt;Element Properties. Can be linked to any element within the inlet or estuary.</td>
</tr>
<tr>
<td>Saltmarsh</td>
<td>Water volume over the marsh and associated area. Saltmarsh on both sides of a channel in a given reach can be included in a single saltmarsh element. Can also be used to represent an upper tidal flat by not setting the Include Saltmarsh condition in Setup&gt;Run Parameters&gt;Conditions. Can be linked to any element within the inlet or estuary.</td>
</tr>
<tr>
<td>Storage</td>
<td>Water volume and area of storage unit. Treated as locally independent of system (not dependent on upstream prism) but contributing to downstream prism. Can be linked to any element within the inlet or estuary but should not have any ‘upstream’ elements.</td>
</tr>
</tbody>
</table>

Using a suitable DGM the volumes and areas can be calculated in one of two ways:

(i) Define a horizontal plane at high and low water level and calculate the water volumes below the plane and the surface areas on the planes.

(ii) Use the surfaces for high and low water derived from a hydraulic model in conjunction with a DGM to calculate the water volumes below the surface and the surface areas at high and low water. This added complexity is not needed for small or relatively short estuaries but can be important for longer estuaries that are near resonant (Thames, Humber, Severn, etc).

It is also possible to define elements as sediment volumes rather than wet volumes. If this is preferred, then the sediment transport coefficient, n, should be expressed as a negative value. This was the basis for the original model development which used fixed surface areas (Kragtwijk et al., 2004; Stive et al., 1998) and works for this form of configuration.

The bulk density of sediment relates to the density of the bed within the element. This is included to take account of the consolidation of sediment that is deposited and is used in the code to adjust the vertical rate of exchange. The default value of 1350kg.m$^{-3}$ is typical for many UK estuaries.

The sediment transport coefficient reflects the nature of the transport process. For simple diffusion a value of 2 can be adopted. Where bed or suspended transport dominate a value between 3 and 5 may be more appropriate. As this model is considering long-term evolution it can be argued that the process can be treated as essentially diffusive, suggesting a value of 2. Furthermore, it is the product of n and cE that determines the morphological response time, so that using a set value may simply result in a slightly different value of cE.

The vertical exchange (although not strictly a sediment fall velocity) should be based on the fall velocity for the sediment type that characterises most of the element. There is an inter-dependence between the fall velocity and the horizontal exchange which is explained further in the Section on Dispersion.
4.2 Dispersion

4.2.1 Exchange between channel elements (and channel and delta)

The horizontal diffusion coefficient is related to the vertical exchange by the relationship:

\[
\frac{D}{uh} = \varepsilon \frac{u}{w_s}
\]

where \(u\) is the velocity (at mtl or peak) between two channel elements, \(h\) is the hydraulic depth (assumed to be at mtl) and \(w_s\) is the vertical exchange. The basis of this equality is explained in Wang et al. (2007), where the parameter \(\varepsilon\) is a coefficient of proportionality, which is suggested as a calibration coefficient of order 0.1. Given the uncertainty in defining the horizontal exchange coefficient, as set out below, the coefficient is taken to be unity and accounted for by simply adjusting the horizontal exchange values directly.

For use within ASMITA, this has to be expressed as a horizontal rate of exchange between elements, given by:

\[
\delta = \frac{D \cdot A}{L_x}
\]

where \(A\) is the cross-sectional area between the elements and \(L_x\) is the distance between the two elements. However, this is rather dependent on how the elements happen to be defined and a better way of determining \(L_x\) is to use the tidal excursion distance given by:

\[
L_x = u_p \cdot T_P / \pi
\]

where \(u_p\) is the peak velocity and \(T_P\) is the tidal period in seconds and simply assumes a sinusoidal variation in velocity over the tidal cycle. Model output can be used to define the excursion, if available.

4.2.2 Exchange between channel and flats

Three methods have been used to-date for estimating the exchange between channel and flats.

(i) Use the channel estimate of \(\delta\), equation (2), and replace the csa, \(A\), with the \(A_{int}\), given by:

\[
A_{int} = L_R \cdot tr / 2
\]

where \(L_R\) is the length of the element (reach) and \(tr\) is the tidal range. The half makes this an average value based on the variation between high and low water.

(ii) Use equation (1) with the hydraulic depth based on the values for the tidal flat (note: this can be estimated using \(h_f = V_f/S_f\)). Then obtain \(\delta\) from equation (2), with the value of \(A\) defined by \(A_{int}\) as given in equation (4).

(iii) Use the rate of propagation across the tidal flat to estimate the transverse velocity:

\[
u_f = \pi W_f / (n_{bk} \cdot T_P)
\]

where \(W_f\) is the average width of the tidal flats and can be estimated from \(S_f/L_R\) and \(n_{bk}\) is the number of banks with flats associated with the width, \(W_f\). Then use equation (1) with \(h_f\) and \(u_f\) to obtain \(D_f\). The horizontal exchange onto the flat is then given by a modified form of equation (2):

\[
\delta_f = D_f \cdot A_{int} / W_f
\]

Experience to-date suggests that the third method is the most suitable but further work is needed to establish which of these is the most appropriate.
4.3 Advection
The model provides for advective flows through the system. Necessarily the flow in and out of an element must sum to zero and the code checks for this. The use of this facility is typically to include one or more river flows into the system. If a flow is introduced into the most upstream (landward) channel element then this must be propagated through each of the downstream channel elements to the open sea boundary. (For a single channel system, this means there should be the same flow in and out of the channel element).

Each inflow to the system can however, have a different sediment load. This is specified as the concentration imported by advection in Setup>River, expressed as a concentration density (kg.m$^{-3}$) and an estimate can usually be obtained from measured data of the riverine input.

It is important to recognise that the model is seeking to impose an equilibrium concentration over the system as a whole, as the basis for volumetric equilibrium. This is why the option to take account of the flow in the definition of the equilibrium condition can be included by checking the box in Setup>Run Parameters>Conditions. (The basis of the flow adjustment to the equilibrium condition is explained in (Townend et al., 2016a)). If this option is not checked the flow conditions are in effect a perturbation to the system. The magnitude of this influence can be explored by setting all other changes (forced changes, transgression, slr and tidal range) to zero and running the model with and without this box checked. When the ‘River Flow offset’ option is selected the element volumes should remain constant. When it is not selected the response will depend on the model configuration.

For a single (channel) element model a concentration associated with advective flow through the element, that is less than \(c_E\), will give rise to net export from the system. This is because the advective flow out of the element is removing sediment at the concentration of \(c_E\), whereas the inflow is only replacing this at the lower rate. The converse is obviously the case when the concentration of the inflow is larger, resulting in net import. It also follows that a value that is equal to \(c_E\) is equivalent to the no flow case.

For a multi-element definition of the channel, this is no longer the case, providing the dispersion between channel elements varies, and there are two or more channel elements, the element connected to the river inflow will adjust according to the exchange with the downstream element and this is distinct from the exchange of the last element that is connected to the open sea environment. The system can therefore co-adjust to take account of the different concentrations at the respective boundaries.

4.4 Interventions
Changes introduced by developments on an estuary can be represented as perturbations to the system at a given time step, or over a defined time interval. This might be useful to represent a capital dredge and the subsequent maintenance dredging as a series of volume changes in the relevant channel elements. If the dredging impacts on the tidalflats then associated changes in the areas of the tidalflat and channel elements may also need to be defined. Similarly, a reclamation could be defined as a loss of volume and area (usually on the tidalflats).

N.B in version 1.3 such interventions are not constrained and so reclamations are not ‘fixed’ but act as “soft” perturbations that may subsequently accrete or erode.
4.5 Saltmarsh

Saltmarsh elements can be specified by defining the water volume over the marsh and its surface area in a given reach. There is not a lot of available data with which to define the properties of saltmarsh species (see HR Wallingford report IT.573 for a review of available data). The following table gives some indicative parameter values based on species reported in the literature. Some information is provided by Randerson (1979) as modelled peak biomass for a range of species and the zonation information is gleaned from the work of Gray (1992). Lower and upper species bounds are given as factors, $\kappa$, of the MHWN elevation (mODN) so that the depth is given $D = a - \kappa z_{MHWN}$, where $a$ is the tidal amplitude. Some data on species ranges in Venice Lagoon are presented by Silvestri et al. (2005) as given in the columns headed (VL) below.

<table>
<thead>
<tr>
<th>Species</th>
<th>Min depth factor, $\kappa$</th>
<th>Max depth factor, $\kappa$</th>
<th>Min depth (VL)</th>
<th>Max depth (VL)</th>
<th>Max biomass kg.m$^{-2}$</th>
</tr>
</thead>
<tbody>
<tr>
<td>Spartina</td>
<td>1.7</td>
<td>1.2</td>
<td>0.13</td>
<td>0.28</td>
<td>0.8</td>
</tr>
<tr>
<td>Puccinella</td>
<td>1.9</td>
<td>1.5</td>
<td>0.08</td>
<td>0.18</td>
<td>1.5</td>
</tr>
<tr>
<td>Halomione</td>
<td>1.9</td>
<td>1.55</td>
<td>0.03</td>
<td>0.13</td>
<td>1.7</td>
</tr>
<tr>
<td>Salicornia</td>
<td>1.8</td>
<td>1.4</td>
<td>0.18</td>
<td>0.38</td>
<td>0.2</td>
</tr>
<tr>
<td>Limonium</td>
<td>-</td>
<td>-</td>
<td>0.13</td>
<td>0.23</td>
<td>-</td>
</tr>
<tr>
<td>Sarcocornia</td>
<td>-</td>
<td>-</td>
<td>0.03</td>
<td>0.28</td>
<td>-</td>
</tr>
<tr>
<td>Sueada</td>
<td>1.8</td>
<td>1.4</td>
<td>-</td>
<td>-</td>
<td>0.2</td>
</tr>
<tr>
<td>Aster</td>
<td>1.8</td>
<td>1.2</td>
<td>-</td>
<td>-</td>
<td>0.6</td>
</tr>
</tbody>
</table>

For North Inlet delta in US, Morris et al. (2002) suggest values of $q_m = 0.00018$ yr$^{-1}$ and $k$ in the range 1.5-2.4x10$^{-2}$ m$^3$kg$^{-1}$yr$^{-1}$ for short and tall forms of S. alterniflora respectively. Mudd et al. (2004) suggest a value of $k_b = 1.68x10^{-4}$ yr$^{-1}$ and Marani et al. (2007) use $k_m = 2.4x10^{-3}$ m$^3$kg$^{-1}$s$^{-1}$. Each of these authors uses a slightly different representation of $k$ hence the different dimensions. ASMITA OO uses values with the same dimensions as Morris’ $k$ and the range he cites can be used as initial estimates. Using the parameter values given in Mudd et al. (2004), it is possible to derive estimates of $\alpha$ and $\beta$ as $\alpha = 3.4x10^{-5}$ s$^{-1}$ and $\beta = 0.5$ using the tabulated values, and $\alpha = 4.2x10^{-5}$ s$^{-1}$ and $\beta = 0.56$ using the equation in Figure 3 of the paper.

For saltmarsh to be included as a bio-geomorphological element with biomass production the ‘Include saltmarsh biomass’ box needs to be checked in Setup>Run Parameters>Conditions. If this is NOT checked the saltmarsh is treated the same as other elements and the equilibrium volume is based on the tidal prism relationship using the parameters specified for saltmarsh for the selected equilibrium coefficient set. This is specified by selecting an equilibrium coefficient set in Setup>Run Parameters>Equilibrium Coefficients (the coefficients are defined in UserPrismCoeffs.m).

The utility in Setup>Saltmarsh>Equilibrium marsh depth: (see Section 3.4) allows the influence of the defined saltmarsh properties to be explored by varying species productivity. This can be a useful diagnostic in helping to understand the role of the saltmarsh with the defined model setup.
4.6 Storage
Storage areas are independent of the main channel network and can be linked to channel or flat elements. The volume of water exchanged contributes to the downstream prism of the estuary but the estuary does not influence the storage element, other than controlling the rate of sediment supply. The basis for defining equilibrium of this type of sub-system is poorly defined and needs further development. The current model defines the equilibrium volume based on the tidal prism in the same way as other elements. This is specified by selecting an equilibrium coefficient set in Setup>Run Parameters>Equilibrium Coefficients (the coefficients are defined in UserPrismCoeffs.m).

5 User functions
To allow further research of system behaviour to be undertaken without disrupting the underlying model structure, selected functions have been made external to the class definitions.

5.1 AsmitaModel
The core Asmita model is written as an interface which is then implemented by AsmitaModel where the user can overload any of the functions in the underlying AMinterface definitions. This is illustrated by the inclusion of the function asmitaEqFunctions in AsmitaModel.m.

5.2 UserPrismCoeffs
The default method for calculating the equilibrium volumes is as a function of tidal prism in the form:
\[ V_e = \alpha \cdot P^\beta \]
where \( P \) is the tidal prism upstream of the element (including the prism within the reach that the element belongs to) and \( \alpha \) and \( \beta \) are coefficients that have been found to provide a means of representing the relationship between cross-sectional area and prism (the so called O’Brien or Jarrett relationship), which can also be used to characterise other gross properties of estuary systems (Townend, 2005). The choice of coefficients is selected from the list of available coefficient sets using Setup>Run Parameters>Equilibrium Coefficients. The coefficient sets are defined in the UserPrismCoeffs.m external function for each element type. Using default values of 1 and setting the ‘Scale to initial values flag’ (Setup>Run Parameters>Conditions), has the effect of setting \( \alpha = V_{in}/P \), where \( V_{in} \) is the element volume at time \( t=0 \).

Setting element type specific values (as is the examples in the file provided) results in \( V_e \) being calculated using these values. If the ‘Scale to initial values flag’ is set, \( V_e \) is scaled based on the initial ratio of \( V_{in}/V_e \). This allows two scenarios to be considered:

(i) With element specific parameters defined and no scaling based on initial conditions, any difference with the defined element volumes at \( t=0 \) is a perturbation and the system will seek to adjust to the defined equilibrium conditions

(ii) With element specific parameters defined and scaling based on initial conditions, There is no initial perturbation but any non-linear variation over time is represented. This captures the assumption that the values used at the start of the run are close to an equilibrium condition but may not agree with exactly with the equation being used and so are adjusted to remove this initial difference by re-scaling them.

This function can be varied in conjunction with changes in AsmitaModel (see Section 5.1) to introduce different relationships to define the equilibrium conditions. The default and two cases are included in the version of UserPrismCoeffs provided, which are for the Venice and Amelander models (Humber...
uses the default settings in the example file provided). Note that in the Amelander model a constant value is assigned to tidalflat equilibrium by setting alpha to this value and beta to zero.

5.3 UserSLRrate
The rate of sea level rise is defined in Setup>Estuary> Water Levels and can be positive or negative. The amount of sea level rise at time, t, is computed in UserSLRrate.m.

By defining a rate <-9 m/year, an alternative calculation is applied. In the example file this is a linear rise of 1mm/year prior to 1900 and an exponential rate of increase thereafter that approximates IPCC projections used in the UK (circa 2010). [Note: for this to work the Start Year (set in Setup>Run Parameters>Time Step) must be prior to 1900.] However, this function can be replaced by any function that returns the amount of sea level rise at model run time from t=0.

5.4 UserUnitTesting
This function is for developers to test differences against existing cases when the code is modified. It makes use of the class AsmitaTest and currently can run with one of three models: Humber 3EM.mat, Venice 9EM.mat Severn 16EM.mat. The model setup files are supplied as read only and if unmodified are compatible with the results files provided. These are named HumberTestData.mat, VeniceTestFile.mat, SevernTestFile.mat(also all read only). To run a particular case simply run UserUnitTesting from the command prompt and select a case from the list dialog box. All prompts from Asmita OO are suppressed when run via this utility.

6 Program Structure
The overall structure of the code is illustrated schematically in Figure 17. This is implemented through a number of classes that handle the graphical user interface and program workflows and a number of classes that represent parts of the system. The former comprises the following classes:

- **GUIImage** – basic functionality of model GUI
- **Asmita** – implements GUIinterface for ASMITA application
- **DataGUIinterface** – basic functionality for Data selection
- **AsmitaPlots** – implements DATAGUIinterface to plot results
- **Project** – details of setup and model runs (scenarios)
- **ConstantData** – defines constants used in model
- **RunProps** – defines run time properties (eg time step)
- **RunModel** – handles the initialisation, running and posting of model results
- **AMinterface** – basic functionality of the Asmita model
- **AsmitaModel** – implements AMinterface allowing specific applications to overload function in the basic implementation provided in the interface
- **Results** – store model run results as scenarios and handle saving scenarios to an excel file
The classes to define the inlet or estuary system, currently include the following:

**Estuary** – properties and methods for system as a whole such as dispersion and linkages
**Reach** – setup and provide access to properties for reaches (a channel element plus linked elements)
**Element** – setup and provide access to element properties
**Advection** – handles all types of advective flow, including rivers, drift and tidal pumping
**Rivers** – setup and provide access to river flow/sediment inputs
**Drift** – setup and provide access to littoral drift sediment inputs
**Interventions** – setup and provide access to imposed changes to system geometry (volume and area)
**WaterLevels** – setup and access to water level definitions, tidal properties and changes over time
**Saltmarsh** – setup and access to saltmarsh properties and functions to define behaviour

**Hydraulics** – not yet implemented.

The order in which functions are called during initialisation and runtime is important because of the interdependence of parameters across the various classes. The call sequence is detailed in Appendix A – Function call sequence in RunModel and the UML class diagrams are included in Appendix B – UML Class diagrams.

### 7 Additional References


Appendix A – Function call sequence in RunModel

The following table provides a listing of the calls made in RunModel and the dependency of the functions called on other (sub) functions, along with a summary of the input and output parameters using the model notation (see individual functions or class property definitions for full explanation of variables).
null
Appendix B – UML Class diagrams

### ConstantData
- Constants
- SecType
- Gravity
- KinematicViscosity
- MinimumTimeStep
- SedimentDensity
- vDate
- vNumber
- WastedDensity
- y2s
  - ConstantData()
  - retddConstantData() 
  - setedConstantData() 

### Project
- CaseDescription
- CaseID
- FileID
- PathName
- ProjectDue
- ProjectInfo
- ProjectName
  - Project()
  - clearScenarios(mobj)
  - deleteScenario(mobj, CaseId)
  - retddProject() 
  - retedScenario() 
  - setedProject() 
  - saveScenarios(mobj)
  - Scenario()
  - SystemSummary(mobj, wc, -)
  - xddWriteData(mobj, mobj)
  - Scenario().

### TableData
- AddRow()
- ColID
- ColNames
- ColType
- ColWidth
- FltHeight
- Figure
- FigWidth
ik
- Prompt
- RowNames
- Table
- Title
- UserData
  - TableData(varargin)
  - addArrow(-,-,-)
  - addRow(-,-,-)
  - cancel(-,-)
  - getTableData()
  - saveVars(-,-)

### NumInputDialog
- ArrayVars
- DetailValues
- NumLines
- NumVal
- Prompt
- Title
  - NumInputDialog(varargin)
  - cancelInput()
UML diagrams produced using UMLgui available from the Matlab Exchange Forum and developed by Ben Goddard © 2013.