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Preface

CSTmodel Matlab™ App to compute the mean tide level, high and low water levels, tidal velocity
amplitude and river velocity along the length of a convergent estuary using the analytical model of
Cai, Savenije and Toffolon (hence the CST model).

Requirements

The model is written in Matlab™ and provided as Open Source code (issued under a GNU General
Public License) and runs under v2016b or later. CSTmodel uses the muitoolbox and dstoolbox.

Resources

The CSTmodel App and two toolboxes (muitoolbox and dstoolbox) can be downloaded from
www.coastalsea.uk.

Cite as:
Townend, I.H., 2021, CSTmodel manual, CoastalSEA, UK, pp26, www.coastalsea.uk.
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http://www.coastalsea.uk/
http://www.coastalsea.uk/

CSTmodel manual

A L Feb 2024
\—//‘ =

4

6
7

Contents
Lol [3Tod 1 o] TSSOSO RSPV URTTPRRN 1
GELEING STAIMEM ...t e ettt bbb r e 1
2% A o o1 T [V 14 o] USRS 1
211 Installing the t00IDOXES ........ocviiice s 1
2.1.2 INSEAIIING ThE AP ettt e re e besre e sre e 1
N |V, (oo (= IR U o PSSR 1
221 INPUL PAIBMELETS ... e nne e 2
APPHICALION IMIBNUS ...ttt bbb b e nnennen e 2
T8 R 1RSSR 2
30 1o To 1 ST 2
TR T =] (0] (=T o! PO OSSR 2
3.4 ST (1] o RSSO SP RN 3
K TE T = {1 o ISR PSPPSRSO 4
3.6 ANAIYSIS .o r e e e re e be s e e e re e e nreeres 6
3.6.1 o 101 7 Vo U O SRRSO 6
3.6.2 RS LU 1] 0SSR 7
BT HEID ottt 12
B8 A ettt ettt sttt ne e 12
I I U ] B - BT [-od 1 o o OSSPSR 12
3.10  Accessing data from the Command WINAOW ............ccveivriiinininineieeee e 13
SUPPOItING INFOMMELION .....ocuiiiicecc e et re s te e e s beereesbesre s 15
4.1 Basis O the MOUEL .........cooiiiiee et saenne s 15
4.2 DEIVE OULPUL ..ottt bbbttt eb ettt 15
4.2.1 Calling an external fUNCLION ..........cccoiiieii i 16
422 Input and output format for external FUNCLIONS...........ccooviiiiiineiec e 17
423 Pre-defined fUNCLIONS ........ooviieie e st ee e 19
INPUL FIIE FOTMALS ... et be et s re et e be e sreees 20
5.1  Along-channel Model INPUt PrOPEITIES ......cceiveiiiiieie et 20
5.2 Along-channel ObServed PrOPerti€s....... ..o iiiiiiierieiieie e 20
5.3  Velocity and Elevation ODSEIVALIONS ...........ccoeiiiiiieiieee et 21
PrOQIAM SITUCTUIE. ... vietieiie ettt ettt e s et e et e e sbe e sbe e sreesnbeabeesbeenbeenbeenrneas 22
T 0] [TeT o =T o] 1 YOS 24



CSTmodel manual
= Feb 2024

1 Introduction

The CSTmodel App computes the mean tide level, high and low water levels, tidal velocity amplitude
and river velocity along the length of a convergent estuary using the analytical model of Cai, Savenije
and Toffolon (hence the CST model) as described in (Cai, 2014; Savenije, 2012).

2 Getting started

2.1 Configuration
CSTmodel is installed as an App and requires muitoolbox and dstoolbox to be installed. The download
for each of these includes the code, documentation and example files. The files required are:

dstoolbox: dstoolbox.mlthx
muitoolbox: muitoolbox.mltbx
The App file: CSTmodel.mlappinstall

2.1.1 Installing the toolboxes

The two toolboxes can be installed using the Add-Ons>Manage Add-Ons option on the Home tab of
Matlab™. Alternatively, right-click the mouse on the ‘mltbx’ files and select install. All the folder
paths are initialised upon installation and the location of the code is also handled by Matlab™. The
location of the code can be accessed using the options in the Manage Add-Ons UI.

2.1.2 Installing the App

The App is installed using the Install Apps button on the APPS tab in Matlab™., Alternatively, right-
click the mouse on the ‘mlappinstall’ file and select install. Again all the folder paths are initialised
upon installation and the location of the code is handled by Matlab™,

Once installed, the App can be run from the APPS tab. This sets the App environment paths, after
which the App can be run from the Command Window using:

>> CSTmodel;
The App environment paths can be saved using the Set Path option on the Matlab™ Home tab.

Documentation can be viewed from the App Help menu, or the Supplemental Software in the
Matlab™ documentation. The location of the code can be accessed by hovering over the App icon and
then finding the link in the pop-up window.

2.2 Model Set-up
File>New to create a new project space.

Setup>Model Parameters: The Ul requests data for the model variables. Once added the current set of
variables can be viewed using the Inputs tab.

Setup>Run Parameters: The Ul requests data for the model run time variables. Once added the current
set of variables can be viewed using the Inputs tab.

Run> Run model
When the run has completed the user is prompted to provide a description of the model run (scenario).

The run is listed on the Cases tab and the tidal elevations for the most recent run can be viewed on the
Plot tab.

Plot>Plot menu

The results from a run can be selected and plotted. By using the Add button additional model runs can
be included on the plot, allowing different Cases to be compared.
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2.2.1 Input parameters
In the model the CSA and width are defined by a convergent exponential and prismatic section defined

by:
a= a,+ (a,—a,)exp (_X/L,)

where ap is the CSA (or width) at the estuary mouth, ar is the river CSA (or width) and L' is the
exponential convergence length.

The distance to the estuary-river switch provides the option to define different friction and storage
ratios for the reaches up and downstream of this distance. For a single switch point there will be a
single value for the ‘distance from the mouth to the switch point’ and 3 values for both the Manning
friction coefficient and the Storage width ratio (one at the mouth, one at the switch point and one at the
head). If more detailed mapping of friction is required, then the number of switch points should be 2
less than the number of friction and width ratio values specified. E.g., if there are 3 switch points then
there should be 5 values of friction and width ratio.

3 Application Menus

The Ul comprises a series of drop down menus that provide access to a number of commonly used
functions such as file handling, management of run scenarios, model setup, running and plotting of the
results. In addition, Tabs are used to display set-up information of the Cases that have been run. In this
manual text in Red italic refers to drop down menus and text in Green italic refers to Tab titles.

3.1 File
File=New: clears any existing model (prompting to save if not already saved) and a popup dialog box
prompts for Project name and Date (default is current date).

File>Open: existing models are saved as *.mat files. User selects a model from dialog box.
File>Save: save a file that has already been saved.

File>Save as: save a file with a new or different name.

File>Exit: exit the program. The close window button has the same effect.

3.2 Tools
Tools>Refresh: updates Cases tab.

Tools>Clear all>Project: deletes the current project, including setup parameters and all Cases.

Tools>Clear all>Figures: deletes all results plot figures (useful if a large number of plots have been
produced).

Tools>Clear all>Cases: deletes all cases listed on the Cases tab but does not affect the model setup.

3.3 Project
Project>Project Info: edit the Project name and Date.

Project>Cases>Edit Description: select a scenario description to edit.

Project>Cases>Edit Data Set: edit a data set. Initialises a data selection Ul to define the record to be
edited and then lists the variable in a table so that values can be edited. The user can also limit the data
set retrieved based on the variable range and the independent variable (X) or time. This can be useful
in making specific edits (eg all values over a threshold or values within a date range).

2
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Project>Cases>Save: select the Case to be saved from the list of Cases and is prompted to save the
Case as a dstable or a table and then name the file. The dataset dstable or table are saved to a mat file.

Project>Cases>Delete: select the Case(s) to be deleted from the list of Cases and these are deleted
(model setup is not changed).

Project>Cases>Reload: select a previous model run and reload the input values as the current input
settings.

Project>Cases>View settings: display a table of the model input parameters used for a selected model
run (Case).

Project> Import/Export>Import: load a Case class instance from a Matlab binary ‘mat’ file. Only
works for data sets saved using Export.

Project>Import/Export>Export: save a Case class instance to a Matlab binary ‘mat’ file.
These last two functions can be used to move Cases between projects or models.

NB: to export the data from a Case for use in another application (eg text file, Excel, etc), use the
Project>Cases>Edit Data Set option to make a selection and then use the ‘Copy to Clipboard’ button
to paste the selection to the clipboard.

3.4 Setup
The setup menu provides a series of menus to enable different components of the model to be defined.

Setup>Model Parameters: calls Ul to input or edit the model

variables. Once added the current set of variables can be viewed using

Estuary length (m)

the Inputs tab.
Total length of channel to be represented ooog o
Mean tide width at the mouth Width convergence length (m)
23000
Rate of width convergence Area at mouth (mA2)
. . 80000
Mean tide cross-sectional area at the mouth
Area convergence length (m)
Rate of CSA convergence 19000
Width of the river channel AT
Cross-sectional area of the river channel River Area (m*2)
1000
Distance from mouth to points at which the properties below are T ———
adjusted. These are supplemented by the mouth and head distances so | 85000 0000
the number of the following properties should be number of S e e et e e L]

. 60 60 40 20
distances+2.

Storage width ratio [mouth switch head]

Manning friction coefficient as a set of linear along channel variations |2 *'* 1 1
Mean tide level at mouth (mOD)

The storage width ratio is the ratio of the width at high and low water 02
and is also taken to vary linearly based on the defined values at the Tidal ampiitude (m)

switch points. 29
Tidal period (hr)

Tidal period 124

River discharge (m3/s)

250

River discharge

Setup>Run Parameters: calls Ul to input or edit model run time variables. Once added the current set
of variables can be viewed using the Inputs tab.
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Setup>Estuary Properties: prompts the user to select a file containing the estuary form properties from
a text file. The file format is a single header line followed by 5 columns of numeric data, for distance
from mouth, area at mean tide level, width at high water, width at low water, and Mannings N. Further
details on file format are provided in Section 5.1

Setup>Import data> Load data: prompts for file format to be loaded. The options available vary with
Data type and then loads the data and prompts for a description (working title) for the data set. The Ul
first prompts the to load the Along-channel properties file. This is followed by the option to load a
water levels file, with along-channel water levels at intervals over a tidal cycle, and a velocity file,
with along-channel velocities at intervals over a tidal cycle. The properties file is required, whereas the
water levels and velocities files are optional. Further details on the file formats used are given in
Section 5.2 and 5.3.

Setup>Import data > Add data: prompts for file to be added (only one file at a time can be added) and
the Case to use (if more than one Case). Only files with the format used to create the data set can be
used to Add data to a data record and this is selected when the first file is loaded using the Load menu
option. (NB: not used for Imported Data in this App).

Setup>Import data > Delete data: prompts for Case from which some part of the data is to be deleted.

Setup>Import data > Data QC: runs a series of checks on the data. This is only available if defined
for the specific data format.

Setup>Input Data>Model Constants: various constants are defined for use in models, such as the
acceleration due to gravity, viscosity and density of sea water, and density of sediment. Generally, the
default values are appropriate (9.81, 1.36e-6, 1025 , 2650 respectively) but these can be adjusted and
saved with the project if required.

3.5 Run
Run> Run Model: runs model, prompts for Case description which is added to the listing on the Cases
tab and the results can be displayed and plotted from the X-Plot or XT-Plot tabs.

CSTmodel Version: 2.0; Copyright: Oct 2021 0 CSTmodel Version: 2.0; Copyright: Oct 2021

File Tools Project Setup Run Analysis Help ~| [File Tools Project Setup Run Analysis Help
Project Name: Date Created: Project Name: Date Created:
Cases Inputs  Form  X-Plot  XT-Plot  Stats Cases Inputs  Form  X-Plot XT-Plot  Stats
Along channel variation z Along-channel Variation at time, T 2
4 T 16 T
e S . Elavation
e _—— u- P Tidal velocity
2| Ny e River velocity
" o= 1.2 Stokes velocity
[ N . 1r L= 1
= O] MTL 1 £ / P B
o) = S s HWIL %) '-E . £
E ' LwL 08 £ S o : _ N 10 2
€ 2r T Hydraulic depth > ® _, - Nalals £
2 Tidal vlocity | | s O 3 ~ R =
5 e . . L=} w >
> River velocity T 1 1
[} & - p
o JE—— )
W 4 o T e 0.4
02 27 2
-6
- - 0 . . . ]
) - 0 5 10 15
780 5 10 1570'2 Distance from mouth (m) x10%
Distance from mouth (m) x10% Save | [ D Time = 3.5

Use the “>Figure’ button to create a stand-along figure of the X-Plot and the ‘Save’ button to save the
animation to a file for the XT-Plot.
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Run> Derive Output: data that has been added (either as data or modelled values) can be used to
derive new variables. The Ul allows the user to select data and use a chosen selection of
data/variable/range to define either a Variable, XYZ dimension, or Time. Each data set is sampled for
the defined data range. If the data set being rep— ———
sampled includes NaNs the default is for these Catc

to be included (button to right of Var-limits is

1 Select the variables to be used and assign to X Y Z buttons.

set to “+N’). To exclude NaNs press the button e e Functonto selecta archon, or derne a atab expemsion.
so that it displays ‘-N’. o Caseno: 2 S
The selection is assigned by clicking one of the :‘”h‘l Ds.by B
X’ Y or Z buttons. The user is prompted to Case no: 1 (Dataset) uKraav: From > 0.493223 To > 4.51259, zLevels: From>0-
assign a Variable, X'YZ dimension, or Time -

- - - - Case no: 2 (Dataset) uSoulsby: From > 0.00120968 To > 2.7889, zLevels: From
(the options available varies with the type of Y s0Te2s
variable selected) — see Section 4.2 for details g (Mekmakeckn
of how this works. Matlab script to create new variable using t=time and x,y.z (not case sensitive):

o

An equation is then defined in the text box
below using the X, y, z or t variables'. Based on Calciste Functon Clar Close

the user selection the routine applies the

defined variable ranges to derive a new variable. In addition text inputs required by the call and the
model object (mobj) can also be passed.

Adding the comment %time or %rows, allows the the row dimension to be added to the new dataset.
For example if x and y data sets are timeseries, then a Matlab™ expresion, or function call, call can be
used to create a new time series as follows:

X"2+y  %time

The output from function calls can be figures or tables, a single numeric value, or a dataset to be saved
(character vectors, arrays or dstables). External functions should return the table RowNames (e.g.,
time or location) as the first variable (or an empty first variable), followed by the other variables to be
saved.

If there is no output to be passed back the function should return a string variable.
If varout = 'no output'; this suppresses the message box, which is used for single value outputs.
For expressions that return a result that is the same length as one of the variables used in the call, there
is the option to add the variable to the input dataset as a new variable. In all there are three ways in
which results can be saved:

1. Asanew dataset;

2. As an additional variable(s) to one of the input datasets;

3. As an additional variable(s) to some other existing dataset.
For options 2 and 3, the length of the new variables must be the same length (numbere of rows) as the
existing dataset.

An alternative when calling external functions is to pass the selected variables as dstables, thereby also
passing all the associated metadata and RowNames for each dataset selected. For this option up to 3
variables (plus time if defined for a selected variable) can be selected but they are defined in the call
using dst, for example:

[time,varout] = myfunction(dst, 'usertext', mobj);

! Various pre-defined function templates can be accessed using the ‘Function’ button. Alternatively, text can be
pasted into the equation box from the clipboard by right clicking in the text box with the mouse.

5
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dst = myfunction(dst, 'usertext’, mobj);

This passes the selected variables as a struct array of dstables to the function. Using this syntax the
function can return a dstable, or struct of dstables, or a number of variables. When a dstable, or struct
of dstables is returned, it is assumed that the dsproperties have been defined in the function called and
dstables are saved without the need to define the meta-data manually.

Some further details on using this option and the ‘Function’ library available are provided in Section
4.2.

3.6 Analysis

Plotting and Statistical Analysis both use the standard Data selection Ul. These both require Case,
Dataset and Variables to be selected from drop-down lists and assigned to a button. Further details of
how this works are given in Section 3.9.

3.6.1 Plotting

Analysis>Plot menu: initialises the Plot Ul to select variables and produce several types of plot. The
user selects the Case, Dataset, and Variable to be used and the plot Type from a series of drop-down
lists. There are then buttons to create a New figure, or Add, or Delete variables from an existing figure
for 2D plots, or simply a Select button for 3D and 4D plots. The following figures illustrate the options
available.

[ select Data for Plotting - o X 2 D p I Ot

- For each selection choose the Case, Dataset and
1 For a plot (line, bar, etc) select variable and dimension to use for X and Y axes .
2 The Ind button defines X and the Dep button defines Y Varlable to be Used.

3 Where Dep is the dependent variable and Ind is the independent variable

Case Case ne: 1 g B > Assign a variable, or a dimension, to the Var and X
buttons to set the Y and X axes, respectively

Each selection can be scaled (log, normalised, etc)
and the range to be plotted can be adjusted when

Dataset Dataset ~

Variable Transport property -

Type ine . assigning the selection to a button.
var ST ] sl Tanpor oy From> 0T » 085 sca:Lvwr Tme: > Select plot type (line, bar, scatter, stem, etc)
Case no: 1 (Dataset) Time: From > 0 sec To > 50 sec, scale: Linear N CO ntl’Ol BUttOﬂS:

x

— : updates the list of Cases
XY : swaps the X and Y axes

New Add Delete Clear

Slose + : switches between cartesian and polar plot type
If polar selected then Ind assumed to be in degrees.
X Select Data for Plotting - O X 3D p|0t
D .

P2 e 7ea For each selection choose the Case, Dataset and

1 For a contour or surface plot, select a variable with at least 2 dimensions -

2 If the variable has mare than 2 dimensions you will be prompted to select a sub-set Var|ab|e to be Used.

3 Select dimensions to use for the X-Y axes

Case Casenar 1 g B > Assign selections to the Var, X and Y buttons

Take care to ensure that the assignments to X and Y
correctly match the dimensions selected for the
variable (including any adjustment of the dimension

Dataset Dataset -

Variable Transpart property v

Type sut v ranges to be used).
Case no: 1 (Dataset) Transport property: From > 0 To > 0.85, scale: Linear, X > Se | ect p | ot type .
Var  coordinate: From > 0 To > 100, Y co-crdinate: From > 0 To > 150, Time: 25 sec
= Gase no: 1 (Dataset) X co-ordinate: From > 0 Te > 100, scale: Linear
Case no: 1 (Dataset) Y co-ordinate: From > 0 Ta > 150, scale: Linear M: see 2D plOt above.

¥

Select Clear Close

For all plot types, when the data has more dimensions than the plot or animation the user is prompted
to sub-select from the data (by selecting sampling values for the dimensions that are not being used).
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Animations follow a similar workflow. There are buttons at the bottom of each tab to:
Run the selection and create an animation,

Save the animation to a file (the animation needs to have been run first) . There is also an option to
save on the bottom left of the animation figure.

Clear the current selection.

A Select Data for Plotting
20 3D 4D 20T 3DT 40T

o x 2DT animation

For each selection choose the Case, Dataset and
1 For an animation of a line, surface or volume .
2 Select the Variable, Time and the property o define the X-axis Variable to be used.

Case no: 1 5 = > Assign a variable, or a dimension, to the Var, Time
and X buttons.
Each selection can be scaled (log, normalised, etc) and
the range to be plotted can be adjusted when assigning

Dataset Dataset -

Variable Transport property v

e e E the selection to a button.

Var | Froms 0406 To s 0 et X corovdmate: From s 01To > 100, ¥ co-ordmate 18 > Select plot type (line, bar, scatter, stem, etc)
T Case no: 1 (Dataset) Time: From > 0 sec To > 50 sec, scale: Linear Co ntrol Buttonsl

m Case no: 1 (Dataset) X co-ordinate: From > 0 To > 100, scale: Linear — Updates the ||St Of Cases

+ : switches between cartesian and polar plot type

If polar selected, then X assumed to be in degrees and
when prompted select Polar and NOT Rose.

o x 3DT animation
© For an anmaten of a Ine. suace or vome, sclect avarabe i o oast 2 dmensons For each selection choose the Case, Dataset and
S e e et e e St ] e P o e (s Variable to be used.
oot et . . > Assign selections to the Var, Time, X and Y buttons
Take care to ensure that the assignments to Time, X
and Y correctly match the dimensions selected for the
variable (including any adjustment of the dimension

Run Save Clear Close

Select Data for Plotting
20 3D 4D 20T 30T  4DT

Dataset Dataset v
Variable Transport property 5

Type surf v

Case no: 1 (Dateset) Transport property: From > 0 To > 0.85, seale: Linear, Time:
Var | From > 0sec To 50 sec. X coLordimate: From » 0 To.» 100, ¥ o0 ordmate: From ranges to be used).
ino | Caseno: 1 (Dataset) Time: From > 0 sec To > 50 seo, scale: Linear > Select pIOt type
o Case no: 1 (Dataset) X co-ordinate: From > 0 To > 100, scale: Linear
Case no: 1 (Dataset) Y co-ordinate: From > 0 To > 150, scale: Linear Co ntrol Buttons : see 2 DT p | ot above

Run Save Clear Close

Selection of User plot type

Calls the user_plot.m function, where the user can define a workflow, accessing data and functions
already provided by the particular App or the muitoolbox. The sample code can be found in the
psfunctions folder and illustrates the workflow to a simple line plot using x-y data from the 2D tab
and a surface plot using x-y-z data from the 3D tab.

3.6.2 Statistics

Analysis> Statistics: several statistical analysis options have been included within the Statistical
Analysis GUI. The tabs are for General/statistics, 7imeseries statistics, model comparisons using a
TaylorPlot, and the generation of a new record based on the statistics over the /nfervals defined by
another timeseries.

General fab
The General tab allows the user to apply the following statistics to data loaded in ModelUI:

7
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1) Descriptive for X: general statistics of a variable (mean, standard deviation, minimum, maximum,

D w sum and linear regression fit parameters). Only X
Gonorl | Treosries | Taplr | iiernls needs to be defined. The range of the variable can be
1 Far Descriptive stats of a vector variable. only X needs o be defined adjusted When |t |S asslgned to the X button (See

2 [f variable is a malrix, subsample array when assiging to X button
3 For i ion: X i% i , Y is dependent variable

Section 3.9). If the variable being used is a multi-
dimensional matrix (>2D), the user is prompted to
define the range or each additional dimension, or

Case Pevensey wave buoy v -

Datset Dataset v

Yoo (St wave b - select a value at which to sample. The function can
satete - [Dusteiveorx = return statistics for a vector or a 2D array.
o The results are tabulated on the Stats>General tab and
can be copied to the clipboard for use in other
seect cur cose applications.
_ % 2)  Regression: generates a regresion plot of the dependent variable, Y,
against the independed variable, X. For time series data, the default data
Select a regression model: range is the maximum period of overlap of the two records. For other data
e " types the two variables must have the same number of data points. After
ESSZﬂfﬁrﬁa' pressing the Select button, the user is prompted to select the type of model

to be used for the regression. The results are output as a plot with details of
the regression fit in the plot title.

ile Edit sert Tools Desktop Window Help ¥
NEds h AROU9RL- S 08 eDd

lag time: 0.515548 years.

3) Cross-correlation: generates a cross-corrleation plot of
the reference variable, X, and the lagged variable, X (uses
the Matlab “xcorr’ function). For time series data, the
default data range is the maximum period of overlap of
the two records. For other data types the two variables
must have the same number of data points. This produces
a plot of the cross-correlation as a function of the lag in 50
units selected by the user. 0

5 0 5
Lag in years

4) User: calls the function user_stats.m, in which the user can implement their own analysis methods
and display results in the Ul or add output to the project Catalogue. Currently implements an
analysis of clusters as detailed for Timeseries data below.

Timeseries fab
The Timeseries tab allows the user to select a single Timeseries variable and apply any of the
following statistics:

1) Descriptive: general statistics of a variable (mean, standard deviation, minimum, maximum,
sum and linear regression fit parameters). The results are tabulated in a new window and can
be copied to the clipboard for use in other applications.
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<2
Various ‘seasonal’ sub-divisions can be defined. The required D - 0 X
option is selected from the table in the Ul, by selecting a Syntax
cell and then closing the UI. E;iesm'd for calms:
The next Ul prompts for a threshold for calms (values below threshold o
are deemed to be “calm” conditions) and allows the selected ‘seasonal ?e?ioglal dvisions
‘divisions to be changed (if the desired option is not in the default list), -
or edited. The divisions can be expressed in several ways, as detailed OK | [Cancel
below:
Script Result
1 Descriptive statistics for the full-time series
1:1:12]” Descriptive statistics for the full-time series and monthl
p y

values (the .” creates a column vector).

[12,1,2; 3,4,5; 6,7,8; 9,10,11] | Descriptive statistics for the full-time series and seasons based

on groupings — Dec-Feb, Mar-May, Jun-Aug, Sep-Nov shown.

When seasonal statistics are produced with more than 2 seasons a plot is generated. This can be a
cartesian or polar plot of the mean values with error bars used to depict +/- one standard deviation.
The polar plot maps the year as one revolution.

2)

3)

4)

Peaks: generates a new timeseries of peaks over a defined threshold. There are three methods
that can be selected:
1 = all peaks above the threshold,;

2 = the peak value within each up-down crossing of threshold; and
3 = peaks that have a separation of at least ‘tint” hours.

For option 3, the separation between peaks (‘tint”) is also be defined in the pop-up gui. This
can be used to try and ensure that peaks are independent. The peaks are marked on a plot with
the defined threshold. If rejected, new values can be defined. If accepted a new timeseries is
added. This has the class of the Data Type that was used as the source timeseries but is not
appended to that timeseries because the date/times are a subset of the source.

Clusters: The selection process is similar to peaks, where the user defines a threshold,
selection method and time between peaks (for method 3). In addition, the cluster interval is
defined in days. This is the period of time separating two peaks for them to be no longer
considered part of a cluster (e.g. if a sequence of storms occurs every few days they will form
a cluster. If there is then a gap of, say, 31 days to the next storm, with a cluster time interval of
30 days this would be considered as part of the next cluster). Once a selection has been made,
a plot is generated that shows the peaks for each cluster with a different symbol. The user can
either choose a different definition, or accept the definition. Once accepted, the results are
added as a new timeseries, with the class of the Data Type that was used as the source
timeseries. Two values are stored at the time of each peak in the clusters: the magnitude of the
peak; and the number of the cluster to which it belongs (numbered sequentially from the start).
This allows the data for individual clusters to be retrieved, if required.

Extremes: The selection process is similar to peaks, where the user defines a threshold,
selection method and time between peaks (for method 3). A figure is generated with two plots.
The left-hand plot shows the peaks for the defined threshold and the right hand plots shows
the mean excess above the threshold (circles), the 95% confidence interval (dotted red lines)
and the number of peaks (vertical bars + right hand axis) as a function of threshold. This plot
can be used to help identify a suitable threshold for the peak-over-threshold extremes analysis
method. The user can either choose a different definition, or accept the definition. Once
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accepted, the user is prompted to select a plot type. Options are: None; Type 1 —a single
return period plot; Type 2 —a composite plot showing the probability, quantile, return period
and density plots. See Coles (2001) for further details of the method used and the background
to these plots. The results are tabulated on the Stats/Extremes tab and can be copied to the
clipboard for use in other applications.

5) Poisson Stats: user is prompted to select a threshold, method and peak separation (see Peaks
above) and the function generates a plot of the peak magnitude, time between peaks
(interarrival time) and the duration above the threshold for each peak. The plot shows a
histogram of each variable and the exponential pdf derived from the data, along with the
 value for the fit.

6) User: calls user_stats.m function, where the user can define a workflow, accessing data and
functions already provided by the particular App, or the muitoolbox. The sample code can be
found in the psfunctions folder and illustrates the workflow to produce a clusters plot. Some
code in the header (commented out) shows how to get a time series using the handles passed
to the function (obj and mabj). This code would get the same timeseries as the one passed to
the function. However, by modifying the ‘options’ variable it is possible to access other
timeseries variables.

Taylor fab
The Taylor tab allows the user to create a Taylor Plot using 1D or 2D data (e.g timeseries or grids):

A Reference dataset and a Test dataset are selected. Datasets need to be the same length if 1D, or same
size if 2D. If the data are timeseries they are clipped to a time-period that is common to both, or any
user defined interval that lies within this clipped period. The statistics (mean, standard deviation,
correlation coefficient and centred root mean square error) are computed, normalized using the
reference standard deviation and plotted on a polar Taylor diagram (Taylor, 2001).

[The ModelSkill App provides additional tools to test data and the ModelSkill App manual provides
further details of the methods used.]

Selecting New generates a new Taylor Plot. Selecting the Add button adds the current selection to an
existing plot and the Delete button deletes the current selection. The Clear button resets the Ul to a
blank selection.

Once New or Add are selected, the user is asked
whether they want to plot the skill score (Yes/No). If
Yes, then the user is prompted to set the skill score
parameters. As further points are added to the plot,
this selection remains unchanged (i.e. the skill score
Varabe  nahre wave o . is or is not included). To reset the option it is

. necessary to close and reopen the Statistics Ul.

o e T Fom 51072508 0080 o> 113 201933000 If the number of points in the Reference and Test
[zost] Tinear e 010713003 000000 1o + 31122016 233000 datasets are not the same the user is prompted to

select which of the two to use for interpolation.

New Add Delete Clear

Close
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This is the maximum achievable correlation (see Taylor (2001) for

Reference correlation, Ro discussion of how this is USEd).
1

Exponent used in computing the skill score.

Exponent,n
1 Number of points (+/-W) used to define a local window around the ith

Local skill window

" point. If W=0 (default) the local skill score is not computed.
Iteration option (0 or 1) Local skill score is computed for window around every grid cell (=1),
0

or computes score for all non-overlapping windows (=0)

Skill score averaging window (grids only)

8100 13000 2800 14100 Window definition to sub-sample grid for the computation of the
Cancel average local skill score. Format is [xMin, xMax, yMin, yMax].

(a) time series skill score plot (b) grid skill score plot
B Figure 5: Skill Graph - o X B Figure 4: Skill Map = m} X
File Edit View insert Tools Desktop Window Help > File Edit View Insert Tools Desktop Window Help >
Dadde @08 RE Dede @08 R[E
Reference: Pevensey wave buoy: Significant wave height Ref : Grid 1: Elevati
09 Test: Surf zone waves: Inshore wave height Test: Grid 2: Elevation
‘ 20
18
H ‘ 16
o 07 L ‘ ' 14
'u\"" WHﬂ\ ”)uw
Z 06| J ' ’ } / ' g% =
3 | | £ 3
_§ | % 10 §
~ost = s -
6
04 4
03 b= ] 2
2004 2006 2008 2010 2012 2014 2016 2018
Intervals Length intervals

The Taylor Plot shows the Reference point as a green cross and the Test points as coloured circles.
The legend details the summary statistics and the Case List button generate a table figure listing all the
results. These can be copied to the clipboard

Taylor diagram legend includes: B — bias; E”* —
File Edit View Insert Tools Desktop Window Help I_ d RMS diﬁerence
Nedsa0E @ normalise

The normalised standard deviation and correlation
R coefficient are also given in the Case List table,

04 + Reference H H
R along with the global skill score, Sg, and the
06 o O cf #2:B=0.015; E'=0.471 f
. %, RMS eror average local skill score, SI.
g %o
3 0'8%% B Figure 7: Taylor Diagram Summary
B
% o : File Edit View Insert Tools Desktop Window Help >
£ e Nadea
0.94 Copy to clipboard
0.96 L
) [Reference Barend Elevaton |
0.98 of #1: B=0.022; E'=0.518; corr=0.862; ndstd=0.965 for Gerard: Elevation with skill 5.G=0.93, 5.L= . (Ro=1, n=1, W=0, with no overlaps)
0.99 of #2: B=0.015; E'=0.471; corr=0.885; ndstd=0.958 for Maitane: Elevation with skill $.6=0.941, $.L= . (Ro=1, n=1, W=0, with no overlaps)
= 1
0 05 Nomalized st el 2
Case list =
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3.7 Help
The help menu provides options to access the App documentation in the Matlab™ Supplemental
Software documentation, or the App manual.

3.8 Tabs
To examine what has been set-up the Tabs provide a summary of what is currently defined. Note: the
tabs update when clicked on using a mouse but values displayed cannot be edited from the Tabs.

Cases: lists the cases that have been run with a case id and description. Clicking on the first column of
a row generates a table figure with details of the variables for the case and any associated metadata.
Buttons on the figure provide access the class definition metadata and any source information (files
input or models used).

Inputs: tabulates the system properties that have been set (display only).
Form: plot the estuary form properties defined for the model and/or imported from a user file.
X-Plot: displays a plot of the along channel output properties for the selected case (display only).

XT-Plot: displays a plot of the time varying properties at a selected distance along the estuary. (display
only).
Stats: displays a table of results for any analyses that have been run (can be copied to clip board).

3.9 Ul Data Selection

Functions such as Derive Output (3.5), Plotting (3.6.1) and Statistics (3.6.2) use a standardised Ul for
data selection. The Case, Dataset and Variable inputs allow a specific dataset to be selected from drop
down lists. One each of these has been set to the desired selection the choice is assigned to a button.
The button varies with application and may be X, Y, Z, or Dependent and Independent, or Reference
and Sample, etc. Assigning to the button enables further sub-sampling to be defined if required. Where
an application requires a specific number of dimensions (e.g., a 2D plot), then selections that are not
already vectors will need to be subsampled. At the same time, the range of a selected variable can be
adjusted so that a contiguous window within the full record can be extracted. In most applications, any
scaling that can be applied to the variable (e.g., linear, log, relative, scaled, normalised, differences) is
also selected on this Ul. The selection is defined in two steps:

Figure 3: Select variable — m} X Step 1.

Select the property to use and any Iimitsp:g::nzpplied to the data range of the selected Select the attribute to use. This can be the Val’lab|e
or any of its associated dimensions, which are
Select: Significant wave height hd |iSted in the dl’Op-dOWﬂ |ISt

The range for the selection can be adjusted by
editing the text box or using the Edit (Ed) button.

Scaing: Linear v Any scaling to be applied is selected from the
drop-down list.

Range: From > 0.08 To > 4.79 Ed

Select Close

Press Select to go to the next step or Close to quit.

The number of variables listed on the Ul depends on the dimensions of the selected variable. For each
one Select the attribute to use and the range to be applied.

12
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E!F\'gure 3: Select dimension = O X Step 2 ivarlat_)le Only haS
dimension of time.
Select the property to use and any limits to be applied to the range of the selected property
Select: Time v No selection to be made.
Range: From > 01-07-2003 00:00:00 To > 31-12-2019 23:30:00 Ed Ed It range If reqUired
Select Cancel
B Figure 4: Select dimension SRS Step 2 - Variable has 3 dimensions but only
Select the property to use and any limits to be applied to the range of the selected property 2 are needed for the intended use.
Select: X-axis 2 Select the 1% variable to use as a dimension.
Edit range if required.
Range: From > 7900 To > 16900 Ed
Select V-as v Select the 2" variable to use as a dimension.
Range: From > 0 To > 16900 Ed Edlt range If reqUired'
owrs 500 vrs 1000 vrs Use the slider or the Edit (Ed) button to set
Time 4 o == the value of the dimension to use. (A value of
t=500 is selected in the example shown).
Select Cancel
Press Select to accept the selection made.

[NB: Only unused dimensions can be selected from the Select drop-down lists. To adjust from the
default list this can sometimes require that the second Select list-box is set first to allow the first Select
list-box to be set to the desired value.]

The resulting selection is then detailed in full (including the ranges or values to be applied to all
dimensions) in the text box alongside the button being defined.

Note where a variable is being selected as one property and a dimension as a second property, any
sub-selection of range must be consistent in the two selections. This is done to allow variables and
dimensions to be used as flexibly as possible.

3.10 Accessing data from the Command Window

In addition to the options to save or export data provided by the Project>Cases>Save and
Project>Import/Export options, data can also be accessed directly for use in Matlab™, or to copy to
other software packages. This requires use of the Command Window in Matlab™, and a handle to the
App being used. To get a handle, open the App from the Command Window as follows:

>> myapp = <AppName>; e.g., >> as = Asmita;
Simply typing:
>> myapp

Which displays the results shown in the left column below with an explanation of each data type in the
right hand column.

13
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myapp =
<AppName> with properties: Purpose
Inputs:  [1x1 struct] A struct with field names that match all the model parameter input

fields currently

Cases:  [1x1 muiCatalogue] | muuiCatalogue class with properties DataSets and Catalogue. The
former holds the data the latter the details of the currently held
records.

Info: [1x1 muiProject] muiProject class with current project information such as file and
path name.

Constants: [1x1 muiConstants] | muiConstants class with generic model properties (e.g. gravity, etc).

To access current model settings, use the following:
>> myapp.Inputs.<InputClassName>

To access the listing of current data sets, use:

>> cs.Cases.Catalogue

To access imported or model data sets, use:

>> cs.Cases.DataSets.<DataClassName>

If there are more than one instance of the model output, it is necessary to specify an index. This then
provides access to all the properties held by that data set. Two of these may be of particular interest,
RunParam and Data. The former holds the input parameters used for that specific model run.
RunParam is a struct with fields that are the class names required to run the model (similar to Inputs
above). The Data property is a model specific stuct with field names defined in the code for the model
class. If there is only a single table assigned this will be given the field name of ‘Dataset’. To access
the dstable created by the model, use:

>> cs.Cases.DataSets.<DataClassName>(idx).Data.Dataset

>> cs.Cases.DataSets.<DataClassName>(idx).Data.<ModelSpecificName>
To access the underlying table, use:

>> cs.Cases.DataSets.<DataClassName>(idx).Data.Dataset.DataTable

The result can be assigned to new variables as required. Note that when assigning dstables it may be
necessary to explicitly use the copy command to avoid creating a handle to the existing instance and
potentially corrupting the existing data.

14
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4 Supporting Information

4.1 Basis of the model

The model adopted is the solution proposed by Cai, Savenije and Toffolon, which is well suited and
has already been applied to several estuaries (Cai, 2014). The model accounts for the influence of river
discharge on tidal wave propagation and the along channel variation of mean water level. The
analytical solutions are obtained by solving a set of four implicit equations, i.e. phase lag equation,
scaling equation, celerity equation, and damping equation, derived from the conventional 1-
dimensional conservation of mass and momentum equations (Savenije, 2012). In addition, the
resultant residual water level, due to nonlinear friction, has been taken into account by adopting an
iterative procedure. The model reproduces the main tidal dynamics (i.e. tidal amplitude, velocity
amplitude, wave celerity, and phase lag between elevation and velocity) along the estuary axis. This is
referred to here as the CST model. For a full description of the model, readers can refer to Cai et al.
(2014) and related papers (Cai, 2014; Cai et al., 2012a; Cai and Savenije, 2013; Cai et al., 2016; Cai et
al., 2012b; Cai et al., 2013). An application with a more detailed numerical model is provide by Zhang
et al (2016).

4.2 Derive Output

The Run> Derive Output option allows the user to make use of the data held within App to derive
other outputs or, pass selected data to an external function (see Section 3.5). The equation box can
accept t, X, y, z in upper or lower case. Time can be assigned to X, Y, or Z buttons, or simply included
in the equation as t (as long as the data being used in one of the variables includes a time dimension).
Each data set is sampled for the defined data range. If the data set being sampled includes NaNs, the
default is for these to be included (button to right of Variable is set to “+N”). To exclude NaNs press
the button so that it displays ‘-N’. The selection is based on the variable limits defined whenever a
variable is assigned to X, Y or Z using the X, Y, Z buttons.

The equation string entered in the Ul is used to construct an anonymous function as follows:

heq = str2func(['@(t,x,y,z,mobj) ',inp.eqgn]); %handle to anonymous function
[varout{:}] = heq(t,x,y,z,mobj);

or when using dstables:
heq = str2func(['@(dst,mobj) ',inp.eqgn]); %handle to anonymous function

[varout{:}] = heq(dst,mobj);

This function is then evaluated with the defined variables for t, X, y, and z and optionally mobj, where
mobj passes the handle for the main Ul to the function. Some functions may alter the length of the
input variables (x, y, z, t), or return more than one variable. In addition, the variables selected can be
sub-sampled when each variable is assigned to the X, Y, or Z buttons. The dimensions of the vector or
array with these adjustments applied need to be dimensionally correct for the function being called.
This may influence how the output can be saved (see Section 4.2.2).

If the function returns a single valued answer, this is displayed in a message box, otherwise it is saved,
either by adding to an existing dataset, or creating a new one (see Section 4.2.2).

NB1: functions are forced to lower case (to be consistent with all Matlab functions), so any external
user defined function call must be named in lower case.
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Equations can use functions such as diff(x) - difference between adjacent values - but the result is n-1
in length and may need to be padded, if it is to be added to an existing data set. This can be done by
adding a NaN at the beginning or the end:

e.g.: [NaN;diff(x)]
NB: the separator needs to be a semi-colon to ensure the correct vector concatenation. Putting the NaN
before the equation means that the difference over the first interval is assigned to a record at the end of

the interval. If the NaN is put after the function, then the assignment would be to the records at the
start of each interval.

Another useful built-in function allows arrays to be sub-sampled. This requires the array, z, to be
multiplied by an array of the same size. By including the dimensions in a unitary matrix, the range of
each variable can be defined. For a 2D array that varies in time one way of doing this is:

>> [z .*repmat (1, length(t), length(x), length(y))]
NB2: the order of the dimensions t, X, y must match the dimensions of the array, z.

NB3: When using Matlab compound expressions, such as the above sub-sampling expression, the
expression must be enclosed in square brackets to distinguish it from a function call.

Adding the comment %time or %rows, allows the the row dimension to be added to the new dataset.
For example if x and y data sets are timeseries, then a Matlab™ expresion, or function call, can be
used to create a new time series as follows:

X"2+y  %time

4.2.1 Calling an external function

The Derive Output Ul can also be used as an interface to user functions that are available on the
Matlab search path. Simply type the function call with the appropriate variable assignment and the
new variable is created. (NB: the Ul adopts the Matlab convention that all functions are lower case).
Some examples of functions provided in CSTmodel are detailed in Section 4.2.3.

The input variables for the function must match the syntax used for the call from the Derive Output
Ul, as explained above. In addition, functions can return a single value, one or more vectors or arrays,
or a dstable (see Section 4.2.2). If the variables have a dimension (e.g., time) then this should be the
first variable, with other variables following. If there is a need to handle additional dimensions then
use the option to return a dstable.

If there is no output to be passed back, the function should return a variable containing the string 'no
output' to suppress the message box, which is used for single value outputs (numerical or text).

An alternative when calling external functions is to pass the selected variables as dstables, thereby also
passing all the associated metadata and RowNames for each dataset selected. For this option up to 3
variables can be selected and assigned to the X, Y, Z buttons but they are defined in the call using dst,
for example:

[time,varout] = myfunction(dst, 'usertext', mobj);
dst = myfunction(dst, 'usertext’, mobj);
where ‘usertext’ and mobj are call strings and a handle to the model, respectively.

This passes the selected variables as a struct array of dstables to the function. Using this syntax, the
function can return a dstable or struct of dstables, or as variables, containing one or more data sets.
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4.2.2 Input and output format for external functions
There are several possible use cases:

4221 Null refurn

When using a function that generates a table, plots a figure, or some other stand alone operation,
where the function does not return data to the main Ul, the function should have a single output
variable. The output variable can be assigned a text string, or ‘no output’, if no user message is
required, e.g.:

function res = phaseplot(x,y,t,labels)
res = {'Plot completed'}; %or res = {‘no output’}; for silent mode

end

4.22.2 Single value outout
For a function that may in some instances return a single value this should be the first variable being
returned and can be numeric or text, e.g.:

function [qtime,qdrift] = littoraldriftstats(qgs,tdt,varargin)

%Case 1 - return time and drift
gdtime = arrayl;
qdrift = array2;

%Case 2 - return summary value

gtime = mean(array2); %return single value

%Case 3 - return summary text

gtime = sprintf('Mean drift = %.1f',mean(array2)); %return test string

end

4.2.2.3 Using variables
If only one variable is returned (length>1), or the first variable is empty and is followed by one or
more variables, the user is prompted add the variables to:

i) Input Cases — one of the datasets used in the function call;
i) New Case — use output to define a new dataset;
iii) Existing Case — add the output to an existing dataset (data sets for the selected existing
case and the data being added must have the same number of rows.
In each case the user is prompted to define the properties for each of the variables.

Note that variable names and descriptions must be unique within any one dataset.

function y = moving(x,m,fun)
%a single variable is returned with no rows
y is a vector or array

end

or
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function [x,y,z] = afunction(x,m,fun)
%multiple variables returned but the first variable is empty

x=[];

Yy and z are a vectors or arrays

end

When the first variable defines the rows of a table and subsequent variables the table entries, all
variables must be the same length for the first dimension. This is treated as a new Case and the user is
prompted to define the properties for each of the variables.
function [trange,range,hwl,lwl] = tidalrange(wl,t,issave,isplot)
%first variable is row dimension followed by additional variables
trange,range,hwl,lwl are vectors or arrays

end

4.22.4 Using dstables
When the output has multiple variables of a defined type it can be more convenient to define the
dsproperties within the function and return the data in a dstable. This avoids the need for the user to
manually input the meta-data properties. In addition, if the function generates multiple dstables, these
can be returned as a struct, where the struct fieldnames define the Dataset name.
function dst = tidalrange(wl,t,issave,isplot)

%dst is a dstable with variables, dimensions and dsproprties assigned

%as required, or a struct of dstables with the struct fieldnames defining

%each Dataset.
dst = ..

end

Similarly if the input is also using dstables, the syntax is as follows:

function dst_out = myfunction3(dst_in, 'usertext',mobj)
%dst_in is one or more input dstables, ‘usertext’ is some additional
%instruction to the function and mobj is a handle to the model
%allowing access to other datasets. dst_out is either a dstable, or a
%struct of dstables with the struct fieldnames defining each Dataset.
dst = ..

end

Adding functions to the Function library

To simplify accessing and using a range of functions that are commonly used in an application, the
function syntax can be predefined in the file functionlibrarylist. m which can be found in the utils
folder of the muitoolbox. This defines a struct for library entries that contain:

o fname - cell array of function call syntax;
o fvars - cell array describing the input variables for each function;
e fdesc - cell array with a short description of each function.
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New functions can be added by simply editing the struct in functionlibrarylist.m, noting that the cell
array of each field in the struct must contain an entry for the function being added. In addition, a sub-
selection of the list can be associated with a given App based on the class name of the main Ul. To
amend the selection included with an App or to add a selection for a new App edit the ‘switch
classname’ statement towards the end of the function.

The Function button on the Derive Output Ul is used to access the list, select a function and add the
syntax to the function input box, where it can be edited to suit the variable assignment to the XYZ
buttons.

4.2.3 Pre-defined functions
The following examples are provided within CSTmodel, where the entry in the Ul text box is given in
Courier font and X, Y, Z, refer to the button assignments.

Some useful examples include:

1. Moving Average. There are several moving average functions available from the Matlab
Exchange Forum, such as moving.m. The call to this function is:

moving (X, n, 'func') , wWhere X is the variable to be used, n specifies the number of points to
average over and ‘func’ is the statistical function to use (e.g. mean, std, etc). If omitted the mean is
used. Add %time to the call, to include time in the output dataset.

2. Moving average (or similar) of timeseries, over defined duration, advancing at defined interval

movingtime (x, t, tdur, tstep, 'func'),where Xisthe variable to be used and t the
associated datetimes (defined by variable selection), tdur is the duration over which to apply the
statistic, tstep is the interval to advance the start time for the averaging period and ‘func’ is the
statistical function to use (e.g. mean, std, etc). If omitted the mean is used. tdur and tstep are both
duration character strings of form ‘2.5 d’. Any of the following duration intervals ca be used: y, d,
h, m, or s. Returns a time series based on the defined tstep, where the time used is for the
beginning of each stepping interval, i.e. every tstep from the start of the record to the nearest
interval that is less than tdur from the end of the record.

3. Recursive plot. Generates a plot of a variable plotted against itself with an offset (e.g. X(i) versus
X(i+1) ). This is called from the Derive Output GUI using:

recursive plot (x, ’varname’, nint), where X is the variable, ‘varname’ is a text string
in single quotes and nint is an integer value that defines the size of the offset.

4. Phase plot. This function is similar to the recursive plot function but generates a plot based on two
variables that can, optionally, be functions of time. The call to this function is:

phaseplot (X, Y , t),where X and Y are the variables assigned to the respective buttons and
t is time (this does not need to be assigned to a button and t can be omitted if a time stamp for the
datapoints is not required).
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All input functions use ASCII text files.

Input file formats

5.1 Along-channel Model Input Properties

Properties to define the along-channel variation in cross-sectional area and width are loaded using
Setup>Estuary Properties with a file that 1 header line and 4 or 5 columns (including the Manning
coefficient is optional). The columns are: x - Distance from mouth, Amtl - Area at mean tide level,
Whw - Width at high water, Wiw - Width at low water, Manning_N - Mannings N (optional).

E Humber_raw.txt L E] demo_estuary_props.txt E ‘E demo_Xobs.txt L E demo_Uobs.txt Lk

1 Humber 2000 measured: x Amtl Whw Wlw Manning N(optional)
0 84244.29 16002.29132 10478.37793

1498.7 92307.06 10568.45376 6373.531979
4190.59 77367.74 11332.31847 6425.803482
6623.75 64617.04 11647.56352 6340.4899
9850.5354393.19 8182.219804 6260.121396
11320.93 49358.8 5843.379911 4931.790771
13579.51 43051.88 4104.755249 3292.223828
16112.08 35487.28 3976.445614 3056.229749
19042.15 34605.09 4097.9909662875.337093
21475.31 31697.93 4332.578626-3128.883136
24127.11 27350.87 4313.519826 3083.735757

-~ O U

[os]

o

10
11
12

5.2 Along-channel Observed Properties
Observed data to be used to evaluate model results is loaded using Setup>Import Data>Load menu
option. The along-channel properties file format has a 1 line header and 5 columns of data for: dist -
along channel distance, msl - mean water level, z-amp - tidal amplitude, ut-vel - velocity amplitude,
ur-vel — river velocity, hyd-depth - hydraulic depth.

] O N = W

O WO

I
~] 0 N = W

dist

0
1
4
6
9

11.
13.
16.
19.
21.
24.
26.
29.4
31.
34.9
36.
39.

0.217
.5 0.28
.19
.62
.85
32
58
11
04
43
13
05

57

[ T i Y e T e Y i O i Y i T i Y i Y e O i T i T i Y i

58
03

o

.283
.308
.325
.328
.334
.321
.372
.38¢6
.408
L4086
.444
.496
.544
.498
.53

msl z-amp

2.869
2.83

[T O I SO T O AN T O T S T L o T S O T L T S i L

(8}

ut-vel
1.059168694 0.0029675¢

ur-vel

hyd-depth

13.59436663

0.878607182 0.002708352 8.112766743

.848
.867
.875
.887
.896
.931
.912
.922
.935
.966
.994
.984
.011
.092
.147

0.
.8908874
.809520327
.99013511
.044568372
.201749586
.161558969
.166814125
.229040224
.265767951
.370899155
.286373612
.345489334
.445561729
.481257141

[ e =

[

859929251

0.
.003868949
.004596164
.005064953
.005806347
.007044778
.007224371
.00788695

.009140477
.010031479
.012082992
.012631698
.01544371

.017496037
.0197750886

[ T i Y i T e Y i O i Y i i Y i i Y i T e i

o

003231321

7.
.373117664
.80950323
.276226273
.598338326
.370815949
.969696734
.309230543
.152271237
.474870006
.102725712
.277031399
.379800598
.4830967
.336500633

Moy = =] W oW o w -]

o

222529873

Note: ur-vel is included to make the data compatible with the data set generated by the CST model.

Define as a column of zeros if not known.
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5.3 Velocity and Elevation Observations

The format for the Elevation and Velocity files are loaded using Setup>Import Data>Load menu
option when loading the Along-channel properties. The files have a 1 line header, 1 column for time,
and N columns for elevation or velocity at each time interval, where N is the number of distances
included in the along-channel properties file (see above). An example of the first 1.5 hours at 0.25-
hour intervals is shown below where there are 32 columns (text is wrapped to fit in display window).

E Humber_raw.txt ki Edemo_estuary_props.txl X | Edemo_Xobs.lxl X BdemofUubs.txt [x] ‘

1 Nelocity

2 0.25 0.769134245 0.619739443 0.591014743 0.314295733 1.186268646 0.772932472 0.911687966
.529385972 0.669711082 1.005391114 0.749394437 0.77485393 0.675135358 0.380945355 1.150127099
.931788939 0.734149877 0.631133899 0.79351887 0.592535633 0.602870319 0.632055715 0.548954874
.817613133 0.684149789 0.517716359 0.654057518 0.706195211 1.165749941 1.213062554 0.571339612
.58537505
.50.769521232 0.620076179 0.590375421 0.31434531 1.186606945 0.772763129 0.911819985
.529438516 0.66966019 1.006660841 0.749712369 0.774744024 0.676383967 0.381574838 1.150667477
.932271371-0.734577195-0.631982355-0.794392247-0.59301854-0.6028780670.632008003-0.548369041
.817019028 0.683867156 0.516233529 0.65116105 0.703580557 1.160423004 1.20634187 0.568370242
.581948554
.75 0.769423397 0.620080642 0.590821908 0.314353088 1.186990398 0.773004454 0.9118488¢68
.529349001 0.669656609 1.006383621 0.750956726 0.775090002 0.674615762 0.381188842 1.150915177
.932537238-0.734696219 0.631659366-0.794500146-0.593267538-0.602759280.631657550.547943647
.815702294 0.681566213 0.51444867 0.648675833 0.699901843 1.154127265 1.199605215 0.565158225
.579418627

0.769460421 0.620548032 0.590853878 0.314515143 1.186595396 0.772880557 0.912385215
.52933236 0.669596678 1.006787563 0.750173526 0.775059037 0.67618953 0.381571526 1.151558261
.933059707-0.735286877-0.63232233-0.79436725-0.593019361 0.60206134-0.631286859-0.546575204
.812799778 0.679482878 0.512403334 0.645753337 0.696976442 1.149651599 1.19368492 0.563349464
.577512698
.25 0.7€958€6735 0.620659495 0.591606516 0.314442207 1.186968943 0.77321451 0.912346165
.52939756 0.669317663 '1.007119232 0.750898872 0.77515075 0.676977567 0.38196426 1.15235593
.933456334-0.735306438 0.631924765-0.794559442-0.5927133970.6016062860.629558234-0.545558903
.810902009 0.676768962 0.510296028 0.643297759 0.694204671 1.145695127 1.188122789 0.561655479
.576599869
.5 0.77008247 0.620430378 0.590745681 0.314792525 1.187145307 0.773593043 0.912654135
.529711095 0.670032678 1.007466137 0.751489213 0.775737316 0.676520854 0.381879268 1.152395031
.932548952-0.735554082-0.632009711-0.794028033-0.591698776-0.600172974-0.628351109-0.543582715
.807755197 0.674762871 0.50897984 0.641265136 0.691505437 '1.141327947 1.186482715 0.560170805
.575633976

ol
oo oo, o000 OoORrPrROOoOOOHOOOOOCOOODOOODOOOCO
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6 Program Structure
The overall structure of the code is illustrated schematically in Figure 1. This is implemented through
several classes that handle the graphical user interface and program workflows (Main Ul) and several
classes that handle the data manipulation and plotting (Input Uls and Data Uls).

Figure 1 - — High level schematic of program structure

Input Uls

Project

Data Input

Main Ul

Catalogue

'Model/Data |
‘ Classes ‘

Data Uls

Edit, Plot,
etc

The interfaces and default functionality are implemented in the CSTmodel App using the following
muitoolbox classes depicted in Figure 2, which shows a more detailed schematic of the program
structure. See the muitoolbox and dstoolbox documentation for more details.

Figure 2 — schematic of program structure showing how the main classes from muittoolbox and dstoolbox are used

In addition, the CSTmodel App uses the following classes and functions:

table

Variables

Main Ul
User properties
muiModelUl
Inputs Property Input
Data Ul classes muUl dasses
Cases —— iCatal
Uls for plots, . IRl DENE Records
muiProject Info
stats, etc Model/Data .
+— Constants DataSets — muiPropertyUl
. . classes
muiDataUl Properties
dscatalogue Other properties| | PropertyLabels
TabContent TabDispaly
Ulsettings L ET S 2T table ~| Catalogue muiDataSet
Ulselection
Properties CaselD Data dstable
CaseDescription RunParam
CaseClass MetaData DataTable |
CaseType ClassIndex DSproperties —
muitoolbox Inherited class User defined Matlab™
& dstoolbox class

CSTparameters — class to handle input for model parameters

CSTrunparams — class to handle input for model run time parameters

CSTformprops — class to load estuary form properties from a text file
CSTrunmodel — class to handle call to model, tab plot and output definition
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cst_model — CST model code, provided by Cai HuaYang wit the following functions:
cst_x_plot — plot along channel variations on a tab or figure.

cst_xt_plot — plot variations in time or distance on a tab or figure.

cstmodel_update — update saved models to newer versions of CSTmodel.

f _new_2012 — analytical solution for tidal dynamics proposed by Cai, H., H. H. G. Savenije, and M.
Toffolon, 2012, Journal of Geophysical Research, 117, C09023

f_toffolon_2011 — analytical solution for tidal dynamics proposed by Toffolon, M., and H. H. G.
Savenije (2011), J Geophys Res-Oceans, 116,

findzero_new_discharge_river — analytical solution dimensionless parameters for river flow
findzero_new_discharge_tide — analytical solution dimensionless parameters for tide
newtonm — Newton Rapshon root finder
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