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Preface

ModelUl is a Matlab™ App to demonstrate how to use the muitoolbox to create bespoke interfaces for
data analysis and modelling applications that produce some combination of graphical and/or time
series outputs. The muitoolbox is designed to enable the rapid prototyping of models by allowing the
model developer to focus on the model, rather than the functional or operational needs of the software
package itself. To this end, the Ul provides a standard interface with drop-down menus, tools to open
and close files, keep track of model runs, provide a rapid means to implement model set-up and data
import and export, derivation of new variables, and some basic plotting and statistical tools. The
ModelUI package includes three example models to illustrate how to create and modify the Ul for
different applications. These include:

VerticalProfile to illustrate the basic Ul and a simple model producing spatial data
SimpleTide to illustrate handling timeseries data in a similar UL.
Diffusion2D to illustrate how to handle time plus 2 or 3 space dimensions.

Requirements

The model is written in Matlab™ and provided as Open Source code (issued under a GNU General
Public License) and runs under v2016b or later. ModelUI uses the muitoolbox and dstoolbox.

Resources

The ModelUI App and two toolboxes (muitoolbox and dstoolbox) can be downloaded from
www.coastalsea.uk.

Cite as:
Townend, I.H., 2021, ModelUl manual, CoastalSEA, UK, pp26, www.coastalsea.uk.
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Revision history
Version Date Changes
3.0 May 2021 = ModelUI packaged as a Matlab App and migrated to use muitoolbox
and dstoolbox.
2.1 Dec. 2020 | Help text added to function. Various bug fixes. Package core suite as a
toolbox.
2.0 July 2019 | Restructured Ul, Data and Model classes to make Data and Models

independent of class handles defined for a specific Ul. This allows
Data and Model classes to easily be used in any Ul, or for multiple
models to be included within a single Ul. Unfortunately, this means
that Classes developed for version 1.1 need to be updated (a relatively
minor task) because they are no longer compatible.

All imported data sets and model outputs now inherit either TSDataSet
for timeseries data and DSDataSet for table data. These super classes
in turn inherit the generic functions in DataSet. This allows data sets
with different formats to be included in the same class (e.g. imported
wave data with different variables and formats).

Added descriptive and timeseries statistics class (DataStats) and range
of functions (in MUIfunctions) so that Statistical analysis can be
included in the UI.

Added panel to tabs in DataGUlinterface to improve behaviour
Improved behaviour when running multiple Uls/Models
11 June 2018 | Minor corrections to improve cross-platform compatibility

Fixed bugs when setting data ranges in Data GUIs and selecting data
from a pop-up list.

Improved plotting option selection for xyz data with no time
Scenario selection added to control of Plot tab

1.0 Mar 2018 | Full release with some updates to code but no changes to model
structure or requirements.

0.1 Jan 2018 | Preliminary release via www.coastalsea.uk
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1 Introduction

Whether prototyping a new method or writing a new application, dealing with the coding
infrastructure needed to handle the user interface, data input/output and plotting the results can be time
consuming. ModelUI aims to speed up the process and provide users with a standard Ul that can be
rapidly adapted for new applications. This manual explains the functionality of the standard Ul and
how it can be used as the Ul for other models. There are three sample models to illustrate different
ways of using ModelUI. Within ModelUI there is a simple model for vertical velocity profiles. The
SimpleTide model illustrates handling of timeseries data within an interface that uses ModelUI. The
Diffusion2D model illustrates how to handle how to handle time plus 2 or 3 space dimensions with its
own bespoke interface. These models are summarised in Section 4.

The models supplied with ModelUI are used to illustrate how to implement some basic uses of
ModelUl and the muitoolbox. There are two ways of doing this:

() using the ModelUTI interface ‘as is” and adding a new model to the interface.
(i) implementing a bespoke interface to provide the required functionality.

The requirements and options available are explained in the muitoolbox documentation and manual.

A simple model may only require the addition of one new class to implement using default ModelUI
interface. However much more sophisticated applications are also possible. The ASMITA and
CoastalTools applications use muitoolbox to implement bespoke interfaces to meet the needs of the
application. They also provide a resource for many data handling methods that may be of use for other
applications. These include some variations of the default statistical methods, as well as a variety of
alternative plotting options.
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2 Getting started

2.1 Configuration
ModelUl is installed as an App and requires muitoolbox and dstoolbox to be installed. The download
for each of these includes the code, documentation and example files. The files required are:

dstoolbox: dstoolbox.mlthx
muitoolbox: muitoolbox.mltbx
The App file: ModelUl.mlappinstall

2.1.1 Installing the toolboxes

The two toolboxes can be installed using the Add-Ons>Manage Add-Ons option on the Home tab of
Matlab™. Alternatively, right-click the mouse on the ‘mltbx’ files and select install. All the folder
paths are initialised upon installation and the location of the code is also handled by Matlab™. The
location of the code can be accessed using the options in the Manage Add-Ons UI.

2.1.2 Installing the App

The App is installed using the Install Apps button on the APPS tab in Matlab™., Alternatively, right-
click the mouse on the ‘mlappinstall’ file and select install. Again all the folder paths are initialised
upon installation and the location of the code is handled by Matlab™.

Once installed, the App can be run from the APPS tab. This sets the App environment paths, after
which the App can be run from the Command Window using:

>> ModelUl;
The App environment paths can be saved using the Set Path option on the Matlab™ Home tab.

Documentation can be viewed from App Help menu, or the Supplemental Software in the Matlab™
documentation. The location of the code can be accessed by hovering over the App icon and then
finding the link in the pop-up window.

2.2 Model Set-up
File>New to create a new project space.

Setup>Input Data>Model Data

The Ul requests data for the model variables. Once added the current set of variables can be viewed
using the Inputs tab.

Run> Run model
When the run has completed the user is prompted to provide a description of the model run (scenario).

The run is listed on the Cases tab and the tidal elevations for the most recent run can be viewed on the
Plot tab.

Plot>Plot menu

The results from a run can be selected and plotted. By using the Add button additional model runs can
be included on the plot, allowing different Cases to be compared.
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3 Application Menus

The Ul comprises a series of drop down menus that provide access to a number of commonly used
functions such as file handling, management of run scenarios, model setup, running and plotting of the
results. In addition, Tabs are used to display set-up information of the Cases that have been run. In this
manual text in Red italic refers to drop down menus and text in Green italic refers to Tab titles.

3.1 File
File=New: clears any existing model (prompting to save if not already saved) and a popup dialog box
prompts for Project name and Date (default is current date).

File=Open: existing models are saved as *.mat files. User selects a model from dialog box.
File>Save: save a file that has already been saved.

File>Save as: save a file with a new or different name.

File>Exit: exit the program. The close window button has the same effect.

3.2 Tools
Tools>Refresh: updates Cases tab.

Tools>Clear all>Project: deletes the current project, including setup parameters and all Cases.

Tools>Clear all>Figures: deletes all results plot figures (useful if a large number of plots have been
produced).

Tools>Clear all>Cases: deletes all cases listed on the Cases tab but does not affect the model setup.

3.3 Project
Project>Project Info: edit the Project name and Date.

Project>Cases>Edit Description: select a scenario description to edit.

Project>Cases>Edit Data Set: edit a data set. Initialises a data selection Ul to define the record to be
edited and then lists the variable in a table so that values can be edited. The user can also limit the data
set retrieved based on the variable range and the independent variable (X) or time. This can be useful
in making specific edits (eg all values over a threshold or values within a date range).

Project>Cases>Save: select the Case to be saved from the list of Cases and is prompted to save the
Case as a dstable or a table and then to name the file. The dataset dstable or table are saved to a mat
file.

Project>Cases>Delete: select the Case(s) to be deleted from the list of Cases and these are deleted
(model setup is not changed).

Project>Cases>Reload: select a previous model run and reload the input values as the current input
settings.

Project>Cases>View settings: display a table of the model input parameters used for a selected model
run (Case).

Project> Import/Export>Import: load a Case class instance from a Matlab binary ‘mat’ file. Only
works for data sets saved using Export.

Project>Import/Export>Export: save a Case class instance to a Matlab binary ‘mat’ file.
These last two functions can be used to move Cases between projects or models.
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NB: to export the data from a Case for use in another application (eg text file, Excel, etc), use the
Project>Cases>Edit Data Set option to make a selection and then use the ‘Copy to Clipboard’ button
to paste the selection to the clipboard.

3.4 Setup
The setup menu provides a series of menus to enable different components of the model to be defined.

Setup>Import Data: dialog with sub-menu options to Load, Add, Delete, Quality Control. The
availability of these options may vary depending on what is defined in the data specific format file.

Select one or more files to load. Once added the current set of variables can be viewed using the Inputs
tab. When the data has been loaded, the user is prompted to provide a description of the data set
(scenario) and is listed on the Cases tab. The source file(s) area also listed on the Inputs tab.

Setup>Import data> Load data: prompts for file format to be loaded. The options available vary with
Data type and then loads the data and prompts for a description (working title) for the data set.

Setup>Import data > Add data: prompts for file to be added (only one file at a time can be added) and
the Case to use (if more than one Case). Only files with the format used to create the data set can be
used to Add data to a data record and this is selected when the first file is loaded using the Load menu
option.

Setup>Import data > Delete data: prompts for Case from which some part of the data is to be deleted.

Setup>Import data > Data QC: runs a series of checks on the data. This is only available if defined
for the specific data format.

Setup> Input Parameters: enter and edit the specified model parameters.

Setup>Input Data>Model Constants: various constants are defined for use in models, such as the
acceleration due to gravity, viscosity and density of sea water, and density of sediment. Generally, the
default values are appropriate (9.81, 1.36e-6, 1025 , 2650 respectively) but these can be adjusted and
saved with the project if required.

3.5 Run
Run> Run Model: runs model, prompts for Case description which is added to the listing on the Cases
tab.

Run> Derive Output: data that has been added (either as data or modelled values) can be used to
derive new variables. The Ul allows the user to select data and use a chosen selection of
data/variable/range to define either a Variable, XYZ dimension, or Time. Each data set is sampled for

the defined data range. If the data set being
sampled includes NaNs the default is for these
to be included (button to right of Var-limits is
set to “+N”). To exclude NaNs press the button
so that it displays -N’.

The selection is assigned by clicking one of the
X, Y or Z buttons. The user is prompted to
assign a Variable, XYZ dimension, or Time
(the options available varies with the type of
variable selected) — see Section 3.9 for details
of how this works.

EA Derive output = (m] x
Calc
1 Select the variables to be used and assign to X Y Z buttons.

2 You may be prompted to sub- ple the data if multi
3 Use the Function to select a function, or define a Matlab expression.

Case Case no: 2 v -
Datset Datasst
Variable uSoulsby > [

= Case no: 1 (Dataset) uKraav: From > 0.483223 To > 4.51259, zLevels: From > 0
To>25

Case no: 2 (Dataset) uSoulsby: From > 0.00120968 To > 2.7889, zLevels: From

* >0To>25

7 Make selection

Matlab script to create new variable using t=time and x.y.z (not case sensitive):

xy

Calculate Function Clear Close
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An equation is then defined in the text box below using the x, y, z or t variables. Based on the user
selection the routine applies the defined variable ranges to derive a new variable. In addition text
inputs required by the call and the model object (mobj) can also be passed.

Adding the comment %time or %rows, allows the the row dimension to be added to the new dataset.
For example if x and y data sets are timeseries, then a Matlab™ expresion, or function call, call can be
used to create a new time series as follows:

X"2+y  %time

The output from function calls can be figures or tables, a single numeric value, or a dataset to be saved
(character vectors, arrays or dstables). External functions should return the table RowNames (e.g.,
time or location) as the first variable (or an empty first variable), followed by the other variables to be
saved.

If there is no output to be passed back the function should return a string variable.
If varout = 'no output'; this suppresses the message box, which is used for single value outputs.
For expressions that return a result that is the same length as one of the variables used in the call, there
is the option to add the variable to the input dataset as a new variable. In all there are three ways in
which results can be saved:

1. As anew dataset;

2. As an additional variable(s) to one of the input datasets;

3. As an additional variable(s) to some other existing dataset.
For options 2 and 3, the length of the new variables must be the same length (numbere of rows) as the
existing dataset.

An alternative when calling external functions is to pass the selected variables as dstables, thereby also
passing all the associated metadata and RowNames for each dataset selected. For this option up to 3
variables (plus time if defined for a selected variable) can be selected but they are defined in the call
using dst, for example:

[time,varout] = myfunction(dst, 'usertext', mobj);
dst = myfunction(dst, 'usertext’, mobj);

This passes the selected variables as a struct array of dstables to the function. Using this syntax the
function can return a dstable, or struct of dstables, or a number of variables. When a dstable, or struct
of dstables is returned, it is assumed that the dsproperties have been defined in the function called and
dstables are saved without the need to define the meta-data manually.

Some further details on using this option and the ‘Function’ library available are provided in Section
4.4.

3.6 Analysis

Plotting and Statistical Analysis both use the standard Data selection Ul. These both require Case,
Dataset and Variables to be selected from drop-down lists and assigned to a button. Further details of
how this works are given in Section 3.9. The sections below present all the options available.
However, the options enabled vary with each application. This can be changed by editing the
DataUltabs property for Plot and Stats in the setMUI function of the model class (e.g. ModelUl,
SimpleTide or Diffusion2D).

! Various pre-defined function templates can be accessed using the ‘Function’ button. Alternatively, text can be
pasted into the equation box from the clipboard by right clicking in the text box with the mouse.

8
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3.6.1 Plotting

Analysis>Plot menu: initialises the Plot Ul to select variables and produce several types of plot. The
user selects the Case, Dataset, and Variable to be used and the plot Type from a series of drop-down
lists. There are then buttons to create a New figure, or Add, or Delete variables from an existing figure
for 2D plots, or simply a Select button for 3D and 4D plots. The following figures illustrate the options
available.

BSelecr Data for Plotting - o X ZD p|0t
Ll 20 D U T 4G For each selection choose the Case, Dataset and

1 For a plot (line. bar, etc) select variable and dimension to use for X and Y axes

2 The Ind bution defines X and the Dep button defines Y Variable to be used.
3 Where Dep is the dependent variable and Ind is the independent variable . A A A
Case Case o 1 g B > Assign a variable, or a dimension, to the Var and X

buttons to set the Y and X axes, respectively

Each selection can be scaled (log, normalised, etc)
and the range to be plotted can be adjusted when

Dataset Dataset ~

Variable Transport property -

Type ine . assigning the selection to a button.
var ST ] sl Tanpor oy From> 0T » 085 sca:Lvwr Tme: > Select plot type (line, bar, scatter, stem, etc)
| Gase no: 1 (Datase) Time: From > 0 sec To > 50 sec, scale: Linear . Control BUttOﬂS:

— : updates the list of Cases

- * o - XY : swaps the X and Y axes
Slose + : switches between cartesian and polar plot type
If polar selected then Ind assumed to be in degrees.
B Select Data for Platting - O X 3D p|0t

2D 3D 4D 2DT 3DT 4DT

: For each selection choose the Case, Dataset and
e P T 2 oo PN e i Bt e, Variable to be used.

3 Select dimensions to use for the X-Y axes

Case Casenar 1 gl 5 > Assign selections to the Var, X and Y buttons

Take care to ensure that the assignments to X and Y
correctly match the dimensions selected for the

Dataset Dataset ~

varaoee Ll Ll : variable (including any adjustment of the dimension
Type st v ranges to be used).
o] SSSSLrmey T ey o o e X > Select plot type.
= Case no: 1 (Dataset) X co-ordinate: From > 0 To > 100, scale: Linear +
| Gaseno: 1 (DatasenY orndte: From > 0 To > 150, scsle: inear Control Buttons: see 2D plot above.
Select Clear Close
4D
D Select Data for Plotting L For each selection choose the Case, Dataset and
D o0 Rl o T v Variable to be used.
2 e v o vt 1 imonon o wi b anid o sl 3 o 6 > Assign selections to the Var, X, Y and Z buttons
Case Case no: 1 g B Take care to ensure that the assignments to X, Y and
Catase Cataset g Z correctly match the dimensions selected for the
Variaie Transport property v variable (including any adjustment of the dimension
Tope e . ranges to be used).
Var | Fo T aas T S e et oo >0 o 108 o P > Select plot type.
. Case no: 1 (Dataset) X co-ordinate: From > 0 Ta > 100, scale: Linear To produce anew plOt, use the Clear button to remove
Case no: 1 (Dataset) Y co-ordinate: From > 0 To > 150, scale: Linear the preViOUS SeIeCtion

¥

] Case no: 1 (Dataset) Time: From > 0 sec To > 50 sec, scale: Linear

Control Buttons: see 2D plot above.

Select Clear Close

For all plot types, when the data has more dimensions than the plot or animation the user is prompted
to sub-select from the data (by selecting sampling values for the dimensions that are not being used).
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Animations follow a similar workflow. There are buttons at the bottom of each tab to:

Run the selection and create an animation,

Save the animation to a file (the animation needs to have been run first) . There is also an option to

save on the bottom left of the animation figure.

Clear the current selection.

Select Data for Plotting - (]
20 30 4D 20T 30T 4DT

1 For an animation of a line, surface or volume

2 Select the Variable, Time and the property to define the X-axis
3 Ensure that Time and X selections are correctly matched to the dimensions of the variable

Case Case no: 1 vl [+
Dataset Dataset v
Variable Transport property v
Type line =z

Case no: 1 (Dataset) Transport property: From > 0 To > 0.85, scale: Linear, Time:

s From > 0 sec To > 50 sec, X co-ordinate: From > 0 To > 100, Y co-ordinate: 75

= Case no: 1 (Dataset) Time: From > 0 sec To > 50 sec, scale: Linear
ime

Case no: 1 (Dataset) X co-ordinate: From > 0 To > 100, scale: Linear

Run Save Clear Close

Select Data for Plotting - (]
20 3D 4D 20T 30T 4DT
1 For an animation of a line, surface or volume, select a variable with at least 2 dimensions

2 Select the Time and properties to define the X and Y axes
3 Ensure that Time and XY selections are correctly matched to the dimensions of the variable

Case Caseno: 1 7 =

Dataset Dataset v

Variable Transport property ~

Type surf v

Case no: 1 (Dataset) Transport property: From > 0 To > 0.85, scale: Linear, Time:

¥az | From > 0 sec To > 50 sec, X co-ordinate: From > 0 To > 100, ¥ co-ordinate: From
pime | Caseno:1 (Datasel) Time: From > 0 sec To > 50 sec, scale: Linear

. Case no: 1 (Dataset) X co-ordinate: From > 0 To > 100, scale: Linear

= Case no: 1 (Dataset) Y co-ordinate: From > 0 To > 150, scale: Linear

Run Save Clear Close

2DT animation

For each selection choose the Case, Dataset and
Variable to be used.

> Assign a variable, or a dimension, to the Var, Time
and X buttons.

Each selection can be scaled (log, normalised, etc) and
the range to be plotted can be adjusted when assigning
the selection to a button.

> Select plot type (line, bar, scatter, stem, etc)
Control Buttons:

— @ updates the list of Cases

+ : switches between cartesian and polar plot type

If polar selected, then X assumed to be in degrees and
when prompted select Polar and NOT Rose.

3DT animation

For each selection choose the Case, Dataset and
Variable to be used.

> Assign selections to the Var, Time, X and Y buttons

Take care to ensure that the assignments to Time, X
and Y correctly match the dimensions selected for the
variable (including any adjustment of the dimension
ranges to be used).

> Select plot type.

Control Buttons: see 2DT plot above.

Select Data for Plotting

2D 3D 4D 20T 3DT 40T

1 For an animation of a volume, select a variable with at least 3 dimensions
2 Select the Time and properties to define the X Y and Z axes
3 Ensure that Time and XYZ selections are correctly maiched to the dimensions of the variable

Case no: 2 (Dataset) Transport property: From > 0 To > 0.85, scale: Linear, Time:
From > 0 sec To > 50 sec, X co-ordinate: From > 0 To > 100, Y co-ordinate: From
Case no: 2 (Dataset) Time: From > 0 sec To > 50 sec, scale: Linear

Case no: 2 (Dataset) X co-ordinate: From > 0 To > 100, scale: Linear

Case no: 2 (Dataset) ¥ co-ordinate: From > 0 To > 150, scale: Linear

1 Case no: 2 (Dataset) Z co-ordinate: From > 1 To > 3, scale: Linear

Run Save Clear Close

Case Case no: 2 ~ =
Dataset Dataset ~
Variable Transport property v
Type slice -

4DT animation

For each selection choose the Case, Dataset and
Variable to be used.

> Assign selections to the Var, Time, X, Y and Z
buttons

Take care to ensure that the assignments to Time, X, Y
and Z correctly match the dimensions selected for the
variable (including any adjustment of the dimension
ranges to be used).

> Select plot type.

Control Buttons: see 2DT plot above.

10
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Selection of User plot type

Calls the user_plot.m function, where the user can define a workflow, accessing data and functions
already provided by the particular App or the muitoolbox. The sample code can be found in the
psfunctions folder and illustrates the workflow to a simple line plot using x-y data from the 2D tab
and a surface plot using x-y-z data from the 3D tab.

3.6.2 Statistics

Analysis> Statistics: several statistical analysis options have been included within the Statistical
Analysis GUI. The tabs are for Generalstatistics, 7imeseries statistics, model comparisons using a
TaylorPlot, and the generation of a new record based on the statistics over the /nfervals defined by
another timeseries.

General fab
The General tab allows the user to apply the following statistics to data loaded in ModelUI:

1) Descriptive for X: general statistics of a variable (mean, standard deviation, minimum, maximum,

e wm sum and linear regression fit parameters). Only X
General  TmeseriesTaylr _Intervas needs to be defined. The range of the variable can be
3 ForDesrpiue st o et e any X eeds o e et adjusted when it is assigned to the X button (see

3For ion and i X is . Y is dependent variable

Section 3.9). If the variable being used is a multi-
dimensional matrix (>2D), the user is prompted to
define the range or each additional dimension, or
Yoiske (gt v b * select a value at which to sample. The function can
sste | [Ductotntforx z return statistics for a vector or a 2D array.

ve buay (Dataset) Significant wave height: From > 0.08 To > 4.78,
x scale: Li Time: From > 01-07-2003 00:00:00 To > 31-12-2019 23:30:00

Case Pevensey wave buoy o -

Datset Dataset ~

The results are tabulated on the Stats>General tab and
can be copied to the clipboard for use in other

et G Close applications.
n _ M 2) Regression: generates a regresion plot of the dependent variable, Y,
against the independed variable, X. For time series data, the default data
Select a regression model: range is the maximum period of overlap of the two records. For other data
e = types the two variables must have the same number of data points. After
Eﬁg:ﬂfﬁ:ﬁ' pressing the Select button, the user is prompted to select the type of model

to be used for the regression. The results are output as a plot with details of
the regression fit in the plot title.

ile esktop Window Help
Ddde h A0 RL- 2 08 a1

lag time: 0.515548 years.

3) Cross-correlation: generates a cross-corrleation plot of
the reference variable, X, and the lagged variable, X (uses =
the Matlab ‘xcorr’ function). For time series data, the
default data range is the maximum period of overlap of
the two records. For other data types the two variables
must have the same number of data points. This produces
a plot of the cross-correlation as a function of the lag in 50
units selected by the user. g

5 0 5
Lag in years

11
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4) User: calls the function user_stats.m, in which the user can implement their own analysis methods
and display results in the Ul or add output to the project Catalogue. Currently implements an
analysis of clusters as detailed for Timeseries data below.

3.7 Help
The help menu provides options to access the App documentation in the Matlab™ Supplemental
Software documentation, or the App manual.

3.8 Tabs
To examine what has been set-up the Tabs provide a summary of what is currently defined. Note: the
tabs update when clicked on using a mouse but values displayed cannot be edited from the Tabs.

Cases: lists the cases that have been run with a case id and description. Clicking on the first column of
a row generates a table figure with details of the variables for the case and any associated metadata.
Buttons on the figure provide access the class definition metadata and any source information (files
input or models used).

Inputs: tabulates the system properties that have been set (display only).
Q-Plot: displays a quick-plot defined for the class of the selected case (display only).
Stats: displays a table of results for any analyses that have been run (can be copied to clip board).

3.9 Ul Data Selection

Functions such as Derive Output (3.5), Plotting (3.6.1) and Statistics (3.6.2) use a standardised Ul for
data selection. The Case, Dataset and Variable inputs allow a specific dataset to be selected from drop
down lists. One each of these has been set to the desired selection the choice is assigned to a button.
The button varies with application and may be X, Y, Z, or Dependent and Independent, or Reference
and Sample, etc. Assigning to the button enables further sub-sampling to be defined if required. Where
an application requires a specific number of dimensions (e.g., a 2D plot), then selections that are not
already vectors will need to be subsampled. At the same time, the range of a selected variable can be
adjusted so that a contiguous window within the full record can be extracted. In most applications, any
scaling that can be applied to the variable (e.g., linear, log, relative, scaled, normalised, differences) is
also selected on this Ul. The selection is defined in two steps:

Figure 3: Select variable - m} X Step 1.

Select the property to use and any Iimitsp:g::nzpplied to the data range of the selected Select the. attrlbute. to use Th |S can be the Val‘lab|e
or any of its associated dimensions, which are
Select: Significant wave height v IlSIEd in the drop'dOWn ||St

The range for the selection can be adjusted by
editing the text box or using the Edit (Ed) button.

Scaiing: Linear v Any scaling to be applied is selected from the
drop-down list.

Range: From > 0.08 To > 4.79 Ed

Select Close

Press Select to go to the next step or Close to quit.

The number of variables listed on the Ul depends on the dimensions of the selected variable. For each
one Select the attribute to use and the range to be applied.
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E!F\'gure 3: Select dimension = O X Step 2 ivarlat_)le Only haS
dimension of time.
Select the property to use and any limits to be applied to the range of the selected property
Select: Time - No selection to be made.
Range: From > 01-07-2003 00:00:00 To > 31-12-2019 23:30:00 Ed Ed It range If reqUired
Select Cancel
B Figure 4: Select dimension SRS Step 2 - Variable has 3 dimensions but only
Select the property to use and any limits to be applied to the range of the selected property 2 are needed for the intended use.
Select: X-axis [~ Select the 1% variable to use as a dimension.
Edit range if required.
Range: From > 7900 To > 16900 Ed
select Yoaxs v Select the 2" variable to use as a dimension.
Range: From > 0 To > 16900 Ed Edlt range If reqUired'
owrs 500 vrs 1000 vrs Use the slider or the Edit (Ed) button to set
Time 4 o == the value of the dimension to use. (A value of
t=500 is selected in the example shown).
Select Cancel
Press Select to accept the selection made.

[NB: Only unused dimensions can be selected from the Select drop-down lists. To adjust from the
default list this can sometimes require that the second Select list-box is set first to allow the first Select
list-box to be set to the desired value.]

The resulting selection is then detailed in full (including the ranges or values to be applied to all
dimensions) in the text box alongside the button being defined.

Note where a variable is being selected as one property and a dimension as a second property, any

sub-selection of range must be consistent in the two selections. This is done to allow variables and
dimensions to be used as flexibly as possible.

3.10 Accessing data from the Command Window

In addition to the options to save or export data provided by the Project>Cases>Save and
Project>Import/Export options, data can also be accessed directly for use in Matlab™, or to copy to
other software packages. This requires use of the Command Window in Matlab™, and a handle to the
App being used. To get a handle, open the App from the Command Window as follows:

>> myapp = <AppName>; e.g., >> as = Asmita;
Simply typing:
>> myapp

Which displays the results shown in the left column below with an explanation of each data type in the
right hand column.

myapp =
<AppName> with properties: Purpose

13
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Inputs:  [1x1 struct] A struct with field names that match all the model parameter input

fields currently

Cases:  [1x1 muiCatalogue] | muuiCatalogue class with properties DataSets and Catalogue. The
former holds the data the latter the details of the currently held
records.

Info: [1x1 muiProject] muiProject class with current project information such as file and
path name.

Constants: [1x1 muiConstants] | muiConstants class with generic model properties (e.g. gravity, etc).

To access current model settings, use the following:
>> myapp.Inputs.<InputClassName>

To access the listing of current data sets, use:

>> cs.Cases.Catalogue

To access imported or model data sets, use:

>> cs.Cases.DataSets.<DataClassName>

If there are more than one instance of the model output, it is necessary to specify an index. This then
provides access to all the properties held by that data set. Two of these may be of particular interest,
RunParam and Data. The former holds the input parameters used for that specific model run.
RunParam is a struct with fields that are the class names required to run the model (similar to Inputs
above). The Data property is a model specific stuct with field names defined in the code for the model
class. If there is only a single table assigned this will be given the field name of ‘Dataset’. To access
the dstable created by the model, use:

>> cs.Cases.DataSets.<DataClassName>(idx).Data.Dataset

>> cs.Cases.DataSets.<DataClassName>(idx).Data.<ModelSpecificName>
To access the underlying table, use:

>> cs.Cases.DataSets.<DataClassName>(idx).Data.Dataset.DataTable

The result can be assigned to new variables as required. Note that when assigning dstables it may be
necessary to explicitly use the copy command to avoid creating a handle to the existing instance and
potentially corrupting the existing data.
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4 Demonstration models

To illustrate the use of the interface for different types of output (graphical and time series), four
sample models are provided. The first model is provided as the demonstrator model within ModelUI
and computes the vertical tidal current profile. The second model generates a simple tidal curve, and
the third generates an animation of 2D diffusion. These models also illustrate the following types of
change to the core functionality of ModelUI:

SimpleTide — emulates tidal elevation and velocity as timeseries over a specified period.

Diffusion2D — The main purpose of this model is to illustrate the use of tables to hold a multi-
dimensional array that defines a variable at each time-step (eg 1, 2 or 3D arrays to represent a variable
in X, yand z).

The models themselves are briefly summarised in the following sections. How to modify ModelUl, or
develop a new application, is explained in the muitoolbox manual.

4.1 Vertical Tidal Current Profile

The model used in the ModelUl App implements the approach outlined by Prandle (1982) to compute
the variation of the vertical profile given measurements at one elevation. This implementation has the
option to use several different eddy viscosity formulations when computing the profile.

4.1.1 Workflow to Run Model
The following outlines the steps in a typical workflow to setup and run the vertical tidal current profile
mode.:

Define prop... —

File=New — create a new project (name and date)
Bed friction coefficient

Setup>Input Data>Model Data — define model parameters (see o

Prandle (1998) for details of the parameters required. To see the
parameters that are currently set for the model use the Inputs

Nikaurades friction coefficient

0.0025
tab.
. . Tidal period (hours)
File>Save as — save model setup to a *.mat file. 124
Run>Run model — runs the model and prompts user for a Fonrress et
description of the scenario. The results can be viewed on the 0.0008
Q_PIOt tab. Height of velocity measurement above bed (m)
Completed ‘Cases’ are listed based on the user descriptions on 2
the Cases tab. Velocity at depth z (m/s)

1.2

Water depth (m)

4.1.2 Plotting results ;

Results can be plotted using the plotting Ul (Plot>Plot Menu).
Eddy viscosity cases can be selected individually and plotted Cancel
against profiles from other Cases.
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Figure 1 — Vertical profiles from a model run plotted in Ul Plot tab and comparing several Cases using the Plot Menu

4] ModelUI - Version: 1.0; Date: Jan 2018 - m] x 181 )

File Tools Project Setup Run Plot ~ _—
Projact Name: Damo project Dats Created: 18-Feb-2018 7

Scenarios Inputs Plot  Help 16

a Vertical profiles with different eddy viscosity formulations ’ ) _—

12t 1 /
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n
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4.2 Simple tide

SimpleTide provides a simple representation of the diurnal-semidiurnal and spring-neap variations in
the tide based on simple summation of M2, S2 and O1 contributions, scaled to the defined tidal range.
Tidal currents are derived in a similar way and scaled to the defined tidal velocity amplitude. The
model generates a time series of tidal amplitude, vertical and horizontal velocity based on defined
amplitude and phases. The model is implemented in two ways, to illustrate different ways of adding
models

(i) By defining a new class, STData for data input and a model function file simpletidemodel.
This runs within ModelUI and is similar to the implementation of the Vertical Profile model.

(i) by defining three new classes: SimpleTide, STData and STModel. The SimpleTide class
inherits from ModelUI and redirects menu options to STData and STModel. This illustrates a
minimal adjustment to add a new model. The STData and STModel classes simply define a
bespoke data input and replace Model in ModelUI.

4.3 Diffusion model

Diffusion2D implements the 2-D Diffusion equation using a Finite Difference Method. The Numerical
scheme used is first order upwind in time and second order central difference in space, with Implicit
and Explicit options and either Dirichlet or Neumann boundary conditions. The model operates on a
rectangular domain and is perturbed over a defined area at t=0 and then allowed to diffuse at a rate
determined by the diffusion coefficient. This application implements the solution of the 2-D diffusion
equation based on the code developed by Suraj Shanka, Copyright (c) 2012 and made available via the
Matlab ™ Exchange Forum. The main purpose of this application is to provide time varying 2-D data
(and 3-D by replicating the 2-D matrix) to demonstrate the use of variables that have dimension of
time and xyz. A dstable can hold multiple variables for each time step, each with a consistent xyz
definition (i.e. the size of the variable array at each time step is constant). The positions that define
XYZ and Time are stored as properties of the dstable and each (multi-dimensional) variable is a
column vector in the table. If the variable array remains constant but the positions (xyz) change with
time, then xyz need to be added as variables rather than as an xyz definition. The model is
implemented by defining four new classes: Diffusion2D, DFmodel, DFparams and DFrundata. In
addition, the function difffusion2Dmodel does the diffusion computations. DFparams and DFrundata
classes are for data entry, illustrating how to separate out different aspects of the model input
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information. The Diffusion2D class inherits ModelUI to provide model specific functionality and the
DFmodel class implements the control of model runs, tab plot display and holds the model results.

4.3.1 Functions to derive additional outputs
The function userderivedoutput can be called using the Derive Output Ul, to generate either the
integral under the surface at each time step, or the surface gradients at each time step.

For the integral option enter > userderivedoutput(t,x,y,z,’ integral’)

For the gradient option enter > userderivedoutput(t,x,y,z,”gradient’)

& Derive output [ Figure 3: Results Plot - o X
Calc File Edit View Insert Tools Desktop Window Help ~
Ndde B RROVLEA-2 08 =D
Scenario 20x40ints
2
Plot variable Transport property
1.8
Scaling options Linear e ERy
e 18 b EERE
KA T~
Var-limits From->0 To->2.5 14 4 A
[ Transport property from 20x40ints, Linear, Range From->0 To->2.5 12
1
LY X: From->0 To->2
0.8
Ez] Y: From->0 To->3
0.6
Matlab script to create new variable using t=time and x,y.z (not case sensitive): 04 e ANy T
userdefinedoutput(t .y z,'gradient’) 02 D o o 2
0 J
Calculate Clear Close 0 0.5 1 1.5 2 25 3

4.4 Derive Output

The Run> Derive Output option allows the user to make use of the data held within App to derive
other outputs or, pass selected data to an external function (see Section 3.5). The equation box can
accept t, X, y, z in upper or lower case. Time can be assigned to X, Y, or Z buttons, or simply included
in the equation as t (as long as the data being used in one of the variables includes a time dimension).
Each data set is sampled for the defined data range. If the data set being sampled includes NaNs, the
default is for these to be included (button to right of Variable is set to ‘“+N”). To exclude NaNs press
the button so that it displays ‘-N’. The selection is based on the variable limits defined whenever a
variable is assigned to X, Y or Z using the X, Y, Z buttons.

The equation string entered in the Ul is used to construct an anonymous function as follows:
The equation string entered in the Ul is used to construct an anonymous function as follows:
heq = str2func(['@(t,x,y,z,mobj) ',inp.eqn]); %handle to anonymous function

[varout{:}] = heq(t,x,y,z,mobj);

or when using dstables:

heq = str2func(['@(dst,mobj) ',inp.eqn]); %handle to anonymous function

[varout{:}] = heq(dst,mobj);

This function is then evaluated with the defined variables for t, X, y, and z and optionally mobj, where
mobj passes the handle for the main Ul to the function. Some functions may alter the length of the
input variables (x, y, z, t), or return more than one variable. In addition, the variables selected can be
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sub-sampled when each variable is assigned to the X, Y, or Z buttons. The dimensions of the vector or
array with these adjustments applied need to be dimensionally correct for the function being called.
This may influence how the output can be saved (see Section 4.4.2).

If the function returns a single valued answer, this is displayed in a message box, otherwise it is saved,
either by adding to an existing dataset, or creating a new one (see Section 4.4.2 and 3.5).

NB1: functions are forced to lower case (to be consistent with all Matlab functions), so any external
user defined function call must be named in lower case.

Equations can use functions such as diff(x) - difference between adjacent values - but the result is n-1
in length and may need to be padded, if it is to be added to an existing data set. This can be done by
adding a NaN at the beginning or the end:

e.g.: [NaN;diff(x)]

NB: the separator needs to be a semi-colon to ensure the correct vector concatenation. Putting the NaN
before the equation means that the difference over the first interval is assigned to a record at the end of
the interval. If the NaN is put after the function, then the assignment would be to the records at the
start of each interval.

Another useful built-in function allows arrays to be sub-sampled. This requires the array, z, to be
multiplied by an array of the same size. By including the dimensions in a unitary matrix, the range of
each variable can be defined. For a 2D array that varies in time one way of doing this is:

>> [z .*repmat (1, length(t), length(x), length(y))]
NB2: the order of the dimensions t, X, y must match the dimensions of the array, z.

NB3: When using Matlab compound expressions, such as the above sub-sampling expression, the
expression must be enclosed in square brackets to distinguish it from a function call.

Adding the comment %time or %rows, allows the the row dimension to be added to the new dataset.
For example if x and y data sets are timeseries, then a Matlab™ expresion, or function call, can be
used to create a new time series as follows:

X"2+y  %time

4.4.1 Calling an external function

The Derive Output Ul can also be used as an interface to user functions that are available on the
Matlab search path. Simply type the function call with the appropriate variable assignment and the
new variable is created. (NB: the Ul adopts the Matlab convention that all functions are lower case).
Some examples of functions provided in ModelUI are detailed in Section 4.4.3.

The input variables for the function must match the syntax used for the call from the Derive Output
Ul, as explained above. In addition, functions can return a single value, one or more vectors or arrays,
or a dstable (see Section 4.4.2). If the variables have a dimension (e.g., time) then this should be the
first variable, with other variables following. If there is a need to handle additional dimensions then
use the option to return a dstable.

If there is no output to be passed back, the function should return a variable containing the string 'no
output' to suppress the message box, which is used for single value outputs (numerical or text).

An alternative when calling external functions is to pass the selected variables as dstables, thereby also
passing all the associated metadata and RowNames for each dataset selected. For this option up to 3
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variables can be selected and assigned to the X, Y, Z buttons but they are defined in the call using dst,
for example:

[time,varout] = myfunction(dst, 'usertext', mobj);

dst = myfunction(dst, 'usertext’, mobj);

where ‘usertext” and mobj are call strings and a handle to the model, respectively.

This passes the selected variables as a struct array of dstables to the function. Using this syntax, the
function can return a dstable or struct of dstables, or as variables, containing one or more data sets.

4.4.2 Input and output format for external functions
There are several possible use cases:

4421 Null return

When using a function that generates a table, plots a figure, or some other stand alone operation,
where the function does not return data to the main Ul, the function should have a single output
variable. The output variable can be assigned a text string, or ‘no output’, if no user message is
required, e.g.:

function res = phaseplot(x,y,t,labels)
res = {'Plot completed'}; %or res = {‘no output’}; for silent mode

end

4.4.22 Single value oufput
For a function that may in some instances return a single value this should be the first variable being
returned and can be numeric or text, e.g.:

function [qtime,qdrift] = littoraldriftstats(gs,tdt,varargin)

%Case 1 - return time and drift
gdtime = arrayl;
gdrift = array2;

%Case 2 - return summary value

gtime = mean(array2); %return single value

%Case 3 - return summary text

gtime = sprintf('Mean drift = %.1f',mean(array2)); %return test string

end

4423 Using variables
If only one variable is returned (length>1), or the first variable is empty and is followed by one or
more variables, the user is prompted add the variables to:

i) Input Cases — one of the datasets used in the function call;
i) New Case — use output to define a new dataset;
iii) Existing Case — add the output to an existing dataset (data sets for the selected existing
case and the data being added must have the same number of rows.
In each case the user is prompted to define the properties for each of the variables.
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Note that variable names and descriptions must be unique within any one dataset.

function y = moving(x,m,fun)
%a single variable is returned with no rows
y is a vector or array

end

or

function [x,y,z] = afunction(x,m,fun)
%multiple variables returned but the first variable is empty

x=[]

y and z are a vectors or arrays

end

When the first variable defines the rows of a table and subsequent variables the table entries, all
variables must be the same length for the first dimension. This is treated as a new Case and the user is
prompted to define the properties for each of the variables.
function [trange,range,hwl,lwl] = tidalrange(wl,t,issave,isplot)
%first variable is row dimension followed by additional variables
trange,range,hwl,lwl are vectors or arrays

end

4424 Using dstfables
When the output has multiple variables of a defined type it can be more convenient to define the
dsproperties within the function and return the data in a dstable. This avoids the need for the user to
manually input the meta-data properties. In addition, if the function generates multiple dstables, these
can be returned as a struct, where the struct fieldnames define the Dataset name.
function dst = tidalrange(wl,t,issave,isplot)

%dst is a dstable with variables, dimensions and dsproprties assigned

%as required, or a struct of dstables with the struct fieldnames defining

%each Dataset.
dst = ..

end

Similarly if the input is also using dstables, the syntax is as follows:

function dst_out = myfunction3(dst_in, 'usertext',mobj)
%dst_in is one or more input dstables, ‘usertext’ is some additional
%instruction to the function and mobj is a handle to the model
%allowing access to other datasets. dst_out is either a dstable, or a
%struct of dstables with the struct fieldnames defining each Dataset.
dst = ..

end
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Adding functions to the Function library

To simplify accessing and using a range of functions that are commonly used in an application, the
function syntax can be predefined in the file functionlibrarylist. m which can be found in the utils
folder of the muitoolbox. This defines a struct for library entries that contain:

o fname - cell array of function call syntax;
o fvars - cell array describing the input variables for each function;
o fdesc - cell array with a short description of each function.

New functions can be added by simply editing the struct in functionlibrarylist.m, noting that the cell
array of each field in the struct must contain an entry for the function being added. In addition, a sub-
selection of the list can be associated with a given App based on the class hame of the main Ul. To
amend the selection included with an App or to add a selection for a new App edit the ‘switch
classname’ statement towards the end of the function.

The Function button on the Derive Output Ul is used to access the list, select a function and add the
syntax to the function input box, where it can be edited to suit the variable assignment to the XYZ
buttons.

4.4.3 Pre-defined functions
The following examples are provided within ModelUl, where the entry in the Ul text box is given in
Courier fontand X, Y, Z, refer to the button assignments

Some useful examples primarily for timeseries data include:

1. Moving Average. There are several moving average functions available from the Matlab
Exchange Forum, such as moving.m. The call to this function is: < moving(X, n) > where n
specifies the number of points to average over.

2. Down-sampling a time series. This allows a timeseries to be resampled at a different interval (that
must be less than the source timeseries). The call to this function is:

<downsample(x, t, 'period’, ‘'method’)>, where x is the variable to be resampled, time is the
associated time for that variable, period can be ‘year’, ’'month’, *day’, 'hour’, 'minute', ‘second’,
and method can be any valid function call such as ‘mean’, ‘std’, etc. The ‘period’ is required but
the ‘method is optional and if omitted the mean is used.

For timeseries with gaps the ‘nanmean’ function is particularly useful but requires the Statistics
toolbox.

3. Interpolate and add noise. To infill a record with additional points and, if required, add some
random noise to the interpolated values. This is called using:
<interpwithnoise(x, t, npad, scale, method, ispos) %time>, where X is the variable, t is time, npad
is the number of points to add between the existing data points, scale determines the magnitude of
the random noise (a value of O results in an interpolated record with no noise), method is the
Matlab algorithm used for the interpolation (the default is linear) and ispos is a true/false flag
which sets negative values to zero if true.

4. Subsample one record based on a threshold defined for another record (e.g. subsample waves
based on a threshold water level). Function is: <subsample(X, t, thr, mobj) %time>, where X and
t are the variable to be subsampled, thr is the threshold value and mobj is the Ul handle (must be
mobj). The user is prompted to select the dataset and variable to be used to define the condition
and a condition operator (<=, ==, etc). A time series is returned and added as a Derived data set.
The user is prompted to define the metadata for the new data set.
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Recursive plot. Generates a plot of a variable plotted against itself with an offset (e.g. x(i) versus
X(i+1) ). This is called from the Derive Output GUI using: <recursive_plot(X, >varname’, nint)>,

where x is the variable, ‘varname’ is a text string in single quotes and nint is an integer value that
defines the size of the offset.

6. Phase plot. This function is similar to the recursive plot function but generates a plot based on two
variables that can, optionally, be functions of time. The call to this function is:
<phaseplot(X, Y , t)> where X and Y are the variables assigned to the respective buttons and t is
time (this does not need to be assigned to a button and t can be omitted if a time stamp for the
datapoints is not required).

The Function button on the Derive Output Ul provides access to these predefined functions and allows
the user to select one and load a function call template into the Ul equation text box. The list is defined
in the function functionlibrarylist.m which is in the muifunctions folder.
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5 Program Structure
The overall structure of the code is illustrated schematically in Figure 2. This is implemented through
several classes that handle the graphical user interface and program workflows (Main Ul) and several
classes that handle the data manipulation and plotting (Input Uls and Data Uls).

Figure 2 - — High level schematic of program structure

Input Uls }

Project

Data Input

Main Ul

Catalogue

'Model/Data |
‘ Classes ‘

Data Uls

Edit, Plot,
etc

The interfaces and default functionality are implemented in the ModelUl App using the following
muitoolbox classes depicted in Figure 3, which shows a more detailed schematic of the program
structure. See the muitoolbox and dstoolbox documentation for more details.

Figure 3 — schematic of program structure showing how the main classes from muittoolbox and dstoolbox are used
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In addition, the ModelUl App uses the following classes and functions:

VPparam - handles the input of parameters required by the model.
VPdata — allows data to be imported for comparison with the model results.
VPdata_ff —is an alternative to VVPdata (edit call in ModelUI to use this option). The class inherits

muiDataSet but uses the same format file (VPfomrat.m).

dsproperties

Variables
Row
Dimensions

VPmodel — defines model output properties and implements model functions
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VPformat is used by VPdata and defines the read format and metadata for data being imported.

The SimpleTide example application uses the following classes and functions:

SimpleTide - inherits from ModelUI and redirects menu options to STData and STModel
STparam - handles the input of parameters required by the model.

STdata — allows data to be imported for comparison with the model results.

STmodel — defines model output properties and implements model functions.

STformat is used by STdata and defines the read format and metadata for data being imported.
simple_tide is used to compute the variation of tidal elevation and velocity for given constituents.

The Diffusion2D example application uses the following classes and functions:

Diffusion2D — inherits from muiModelUl and defines additional options in the user interface.
DFparams - handles the input of parameters required by the model.

DFrunprops — handles the run time properties.

DFmodel — defines model output properties and implements model functions.

diffusion2Dmodel is a function modified from the code of Suraj Shanka, Copyright (c) 2012,
downloaded from the Matlab™ Exchange Forum.

The function userderivedoutput can be called from the Derive Output menu option. Select the x, y and
z variables of the diffusion dataset as X, Y, Z. The call the function
userderivedoutput(t,x,y,z,<option>), where <option> is either ‘integral’ or ‘gradient’. The user is then
prompted to name the new data set and define the display variable (ResDef). The new data set is saved
as ModelData in the Derived class.
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