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Preface 
CSTmodel  MatlabTM App to compute the mean tide level, high and low water levels, tidal velocity 

amplitude and river velocity along the length of a convergent estuary using the analytical model of 

Cai, Savenije and Toffolon (hence the CST model). 

 

Requirements 
The model is written in MatlabTM and provided as Open Source code (issued under a GNU General 

Public License) and runs under v2016b or later. CSTmodel uses the muitoolbox and dstoolbox. 

 

Resources 
The CSTmodel App and two toolboxes (muitoolbox and dstoolbox) can be downloaded from 

www.coastalsea.uk.  

Cite as: 

Townend, I.H., 2021, CSTmodel manual, CoastalSEA, UK, pp29, www.coastalsea.uk. 
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1 Introduction 
The CSTmodel App computes the mean tide level, high and low water levels, tidal velocity amplitude 

and river velocity along the length of a convergent estuary using the analytical model of Cai, Savenije 

and Toffolon (hence the CST model) as described in (Cai, 2014; Savenije, 2012).  

2 Getting started 
2.1 Configuration 
CSTmodel is installed as an App and requires muitoolbox and dstoolbox to be installed. The download 

for each of these includes the code, documentation and example files. The files required are:  

dstoolbox: dstoolbox.mltbx 

muitoolbox: muitoolbox.mltbx 

The App file: CSTmodel.mlappinstall 

2.1.1 Installing the toolboxes 
The two toolboxes can be installed using the Add-Ons>Manage Add-Ons option on the Home tab of 

MatlabTM. Alternatively, right-click the mouse on the ‘mltbx’ files and select install. All the folder 

paths are initialised upon installation and the location of the code is also handled by Matlab™. The 

location of the code can be accessed using the options in the Manage Add-Ons UI. 

2.1.2 Installing the App 
The App is installed using the Install Apps button on the APPS tab in Matlab™. Alternatively, right-

click the mouse on the ‘mlappinstall’ file and select install. Again all the folder paths are initialised 

upon installation and the location of the code is handled by Matlab™. 

Once installed, the App can be run from the APPS tab. This sets the App environment paths, after 

which the App can be run from the Command Window using: 

>> CSTmodel; 

The App environment paths can be saved using the Set Path option on the Matlab™ Home tab. 

Documentation can be viewed from the App Help menu, or the Supplemental Software in the 

Matlab™ documentation. The location of the code can be accessed by hovering over the App icon and 

then finding the link in the pop-up window. 

 

2.2 Model Set-up 
File>New to create a new project space. 

Setup>Model Parameters: The UI requests data for the model variables. Once added the current set of 

variables can be viewed using the Inputs tab. 

Setup>Run Parameters: The UI requests data for the model run time variables. Once added the current 

set of variables can be viewed using the Inputs tab. 

Run> Run model 

When the run has completed the user is prompted to provide a description of the model run (scenario).  

The run is listed on the Cases tab and the tidal elevations for the most recent run can be viewed on the 

Plot tab.  

Plot>Plot menu 

The results from a run can be selected and plotted. By using the Add button additional model runs can 

be included on the plot, allowing different Cases to be compared.  
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2.2.1 Input parameters 
In the model the CSA and width are defined by a convergent exponential and prismatic section defined 

by: 

𝑎 =  𝑎𝑟 + (𝑎0 − 𝑎𝑟)𝑒𝑥𝑝 (−𝑥
𝐿′⁄ ) 

where a0 is the CSA (or width) at the estuary mouth, ar is the river CSA (or width) and L′ is the 

exponential convergence length.  

The distance to the estuary-river switch provides the option to define different friction and storage 

ratios for the reaches up and downstream of this distance. For a single switch point there will be a 

single value for the ‘distance from the mouth to the switch point’ and 3 values for both the Manning 

friction coefficient and the Storage width ratio (one at the mouth, one at the switch point and one at the 

head). If more detailed mapping of friction is required, then the number of switch points should be 2 

less than the number of friction and width ratio values specified. E.g., if there are 3 switch points then 

there should be 5 values of friction and width ratio. 

 

3 Application Menus 
The UI comprises a series of drop down menus that provide access to a number of commonly used 

functions such as file handling, management of run scenarios, model setup, running and plotting of the 

results. In addition, Tabs are used to display set-up information of the Cases that have been run. In this 

manual text in Red italic refers to drop down menus and text in Green italic refers to Tab titles. 

 

3.1 File 
File>New: clears any existing model (prompting to save if not already saved) and a popup dialog box 

prompts for Project name and Date (default is current date).  

File>Open: existing models are saved as *.mat files. User selects a model from dialog box. 

File>Save: save a file that has already been saved. 

File>Save as: save a file with a new or different name. 

File>Exit: exit the program. The close window button has the same effect. 

 

3.2 Tools 
Tools>Refresh: updates Cases tab. 

Tools>Clear all>Project: deletes the current project, including setup parameters and all Cases. 

Tools>Clear all>Figures: deletes all results plot figures (useful if a large number of plots have been 

produced). 

Tools>Clear all>Cases: deletes all cases listed on the  Cases tab but does not affect the model setup. 

 

3.3 Project 
Project>Project Info: edit the Project name and Date. 

Project>Cases>Edit Description: select a scenario description to edit. 

Project>Cases>Edit Data Set: edit a data set. Initialises a data selection UI to define the record to be 

edited and then lists the variable in a table so that values can be edited. The user can also limit the data 

set retrieved based on the variable range and the independent variable (X) or time. This can be useful 

in making specific edits (eg all values over a threshold or values within a date range). 
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Project>Cases>Save: select the Case to be saved from the list of Cases and is prompted to save the 

Case as a dstable or a table and then name the file. The dataset dstable or table are saved to a mat file.  

Project>Cases>Delete: select the Case(s) to be deleted from the list of Cases and these are deleted 

(model setup is not changed). 

Project>Cases>Reload: select a previous model run and reload the input values as the current input 

settings. 

Project>Cases>View settings: display a table of the model input parameters used for a selected model 

run (Case). 

Project> Import/Export>Import: load a Case class instance from a Matlab binary ‘mat’ file. Only 

works for data sets saved using Export.  

Project>Import/Export>Export: save a Case class instance to a Matlab binary ‘mat’ file. 

These last two functions can be used to move Cases between projects or models. 

NB: to export the data from a Case for use in another application (eg text file, Excel, etc), use the 

Project>Cases>Edit Data Set option to make a selection and then use the ‘Copy to Clipboard’ button 

to paste the selection to the clipboard. 

 

3.4 Setup 
The setup menu provides a series of menus to enable different components of the model to be defined. 

Setup>Model Parameters: calls UI to input or edit the model variables. 

Once added the current set of variables can be viewed using the Inputs 

tab.  

Total length of channel to be represented 

Mean tide width at the mouth 

Rate of width convergence 

Mean tide cross-sectional area at the mouth 

Rate of CSA convergence 

Width of the river channel 

Cross-sectional area of the river channel 

Distance from mouth to points at which the properties below are 

adjusted. These are supplemented by the mouth and head distances so 

the number of the following properties should be number of 

distances+2. 

Manning friction coefficient as a set of linear along channel variations 

The storage width ratio is the ratio of the width at high and low water 

and is also taken to vary linearly based on the defined values at the 

switch points. 

Tidal period 

River discharge 
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Setup>Run Parameters: calls UI to input or edit model run time variables. 

Once added the current set of variables can be viewed using the Inputs tab. 

Time and distance increments to use in the CSTmodel to compute the 

hydraulics (elevation and velocity). If the distance increment is too small 

the model may struggle to converge. Experiment with different distance 

increments if the model terminates with a failure to converge message. 

Option to use imported definition of CSA and widths rather than parameter 

based exponential form. 

Option to output several additional properties (used in EnergyFlux App). 

See Section 4.2 for details. 

 

Setup>Estuary Properties: prompts the user to select a file containing the estuary form properties from 

a text file. The file format is a single header line followed by 5 columns of numeric data, for distance 

from mouth, area at mean tide level, width at high water, width at low water, and Mannings N. Further 

details on file format are provided in Section 5.1. 

Setup>Import Data: prompts for file format to be loaded. The options available vary with Data type 

and then loads the data and prompts for a description (working title) for the data set. The UI first 

prompts to load the Along-channel properties file. This is followed by prompts to load a water level 

Elevation file, with along-channel water level elevations at intervals over a complete tidal cycle1 and a 

velocity file, with along-channel velocities at intervals over a complete tidal cycle2. The properties file 

is required, whereas the water levels and velocities files are optional. Further details on the file formats 

used are given in Section 5.2. 

Setup>User Data: Allows user to define own data import function. See Section 6.1 for details.  

Setup> Model Constants: various constants are defined for use in models, such as the acceleration due 

to gravity, viscosity and density of sea water, and density of sediment. Generally, the default values 

are appropriate (9.81, 1.36e-6, 1025 , 2650 respectively) but these can be adjusted and saved with the 

project if required. 

 

 

1 water level elevations are measured relative to the local topography/bathymetry datum. 
2 velocities are assumed to be total velocities. 
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3.5 Run 
Run> Run Model: runs model, prompts for Case description which is added to the listing on the Cases 

tab and the results can be displayed and plotted from the X-Plot or XT-Plot tabs. 

 

Use the ‘>Figure’ button to create a stand-along figure of the X-Plot and the ‘Save’ button to save the 

animation to a file for the XT-Plot. 

Run> Derive Output: data that has been added (either as data or modelled values) can be used to 

derive new variables. The UI allows the user to select data and use a chosen selection of 

data/variable/range to define either a Variable, XYZ dimension, or Time. Each data set is sampled for 

the defined data range. If the data set being 

sampled includes NaNs the default is for these 

to be included (button to right of Var-limits is 

set to ‘+N’). To exclude NaNs press the button 

so that it displays ‘-N’.  

The selection is assigned by clicking one of the 

X, Y or Z buttons. The user is prompted to 

assign a Variable, XYZ dimension, or Time 

(the options available varies with the type of 

variable selected) – see Section 4.3 for details 

of how this works.  

An equation is then defined in the text box 

below using the x, y, z or t variables3. Based on 

the user selection the routine applies the 

defined variable ranges to derive a new variable. In addition text inputs required by the call and the 

model object (mobj) can also be passed. 

Adding the comment %time or %rows, allows the the row dimension to be added to the new dataset. 

For example if x and y data sets are timeseries, then a MatlabTM expresion, or function call, call can be 

used to create a new time series as follows: 

x^2+y  %time 
 

 

3 Various pre-defined function templates can be accessed using the ‘Function’ button. Alternatively, text can be 

pasted into the equation box from the clipboard by right clicking in the text box with the mouse. 
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The output from function calls can be figures or tables, a single numeric value, or a dataset to be saved 

(character vectors, arrays or dstables). External functions should return the table RowNames (e.g., 

time or location) as the first variable (or an empty first variable), followed by the other variables to be 

saved. 

If there is no output to be passed back the function should return a string variable. 

If varout = 'no output'; this suppresses the message box, which is used for single value outputs. 

For expressions that return a result that is the same length as one of the variables used in the call, there 

is  the option to add the variable to the input dataset as a new variable. In all there are three ways in 

which results can be saved: 

1. As a new dataset; 

2. As an additional variable(s) to one of the input datasets; 

3. As an additional variable(s) to some other existing dataset. 

For options 2 and 3, the length of the new variables must be the same length (numbere of rows) as the 

existing dataset. 

 

An alternative when calling external functions is to pass the selected variables as dstables, thereby also 

passing all the associated metadata and RowNames for each dataset selected. For this option up to 3 

variables (plus time if defined for a selected variable) can be selected but they are defined in the call 

using dst, for example: 

[time,varout] = myfunction(dst, 'usertext', mobj); 
 
dst = myfunction(dst, 'usertext’, mobj); 
 

This passes the selected variables as a struct array of dstables to the function. Using this syntax the 

function can return a dstable, or struct of dstables, or a number of variables. When a dstable, or struct 

of dstables is returned, it is assumed that the dsproperties have been defined in the function called and 

dstables are saved without the need to define the meta-data manually. 

Some further details on using this option and the ‘Function’ library available are provided in Section 

4.3. 

 

3.6 Analysis 
Plotting and Statistical Analysis both use the standard Data selection UI. These both require Case, 

Dataset and Variables to be selected from drop-down lists and assigned to a button. Further details of 

how this works are given in Section 3.9. 

 

3.6.1 Plotting 
Analysis>Plot menu: initialises the Plot UI to select variables and produce several types of plot. The 

user selects the Case, Dataset, and Variable to be used and the plot Type from a series of drop-down 

lists. There are then buttons to create a New figure, or Add, or Delete variables from an existing figure 

for 2D plots, or simply a Select button for 3D and 4D plots. The following figures illustrate the options 

available. 
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2D plot 

For each selection choose the  Case, Dataset and 

Variable to be used. 

> Assign a variable, or a dimension, to the Var and X 

buttons to set the Y and X axes, respectively 

Each selection can be scaled (log, normalised, etc) 

and the range to be plotted can be adjusted when 

assigning the selection to a button. 

> Select plot type (line, bar, scatter, stem, etc) 

Control Buttons: 

→ : updates the list of Cases  

XY :  swaps the X and Y axes 

+ : switches between cartesian and polar plot type 

If polar selected then Ind assumed to be in degrees. 

 

3D plot 

For each selection choose the  Case, Dataset and 

Variable to be used. 

> Assign selections to the Var, X and Y buttons 

Take care to ensure that the assignments to X and Y 

correctly match the dimensions selected for the 

variable (including any adjustment of the dimension 

ranges to be used). 

> Select plot type. 

 

Control Buttons: see 2D plot above. 

 

For all plot types, when the data has more dimensions than the plot or animation the user is prompted 

to sub-select from the data (by selecting sampling values for the dimensions that are not being used). 

 

Animations follow a similar workflow. There are buttons at the bottom of each tab to:  

Run the selection and create an animation,  

Save the animation to a file (the animation needs to have been run first) . There is also an option to 

save on the bottom left of the animation figure. 

Clear the current selection. 
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2DT animation 

For each selection choose the  Case, Dataset and 

Variable to be used. 

> Assign a variable, or a dimension, to the Var, Time 

and X buttons. 

Each selection can be scaled (log, normalised, etc) and 

the range to be plotted can be adjusted when assigning 

the selection to a button. 

> Select plot type (line, bar, scatter, stem, etc) 

Control Buttons: 

→ : updates the list of Cases  

+ : switches between cartesian and polar plot type 

If polar selected, then X assumed to be in degrees and 

when prompted select Polar and NOT Rose. 

 

3DT animation 

For each selection choose the  Case, Dataset and 

Variable to be used. 

> Assign selections to the Var, Time, X and Y buttons 

Take care to ensure that the assignments to Time, X 

and Y correctly match the dimensions selected for the 

variable (including any adjustment of the dimension 

ranges to be used). 

> Select plot type. 

 

Control Buttons: see 2DT plot above. 

 

Selection of User plot type 

Calls the user_plot.m function, where the user can define a workflow, accessing data and functions 

already provided by the particular App or the muitoolbox. The sample code can be found in the 

psfunctions folder  and illustrates the workflow to a simple line plot using x-y data from the 2D tab 

and a surface plot using x-y-z data from the 3D tab. 

 

3.6.2 Statistics 
Analysis> Statistics: several statistical analysis options have been included within the Statistical 

Analysis GUI. The tabs are for General statistics, Timeseries statistics, model comparisons using a 

Taylor Plot, and the generation of a new record based on the statistics over the Intervals defined by 

another timeseries. 

General tab 
The General tab allows the user to apply the following statistics to data loaded in ModelUI:  
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1) Descriptive for X: general statistics of a variable (mean, standard deviation, minimum, maximum, 

sum and linear regression fit parameters). Only X 

needs to be defined. The range of the variable can be 

adjusted when it is assigned to the X button (see 

Section 3.9). If the variable being used is a multi-

dimensional matrix (>2D), the user is prompted to 

define the range or each additional dimension, or 

select a value at which to sample. The function can 

return statistics for a vector or a 2D array. 

 

The results are tabulated on the Stats>General tab and 

can be copied to the clipboard for use in other 

applications. 

 

2) Regression: generates a regresion plot of the dependent variable, Y, 

against the independed variable, X. For time series data, the default data 

range is the maximum period of overlap of the two records. For other data 

types the two variables must have the same number of data points. After 

pressing the Select button, the user is prompted to select the type of model 

to be used for the regression. The results are output as a plot with details of 

the regression fit in the plot title. 

 

 

 

3) Cross-correlation: generates a cross-corrleation plot of 

the reference variable, X, and the lagged variable, X (uses 

the Matlab ‘xcorr’ function). For time series data, the 

default data range is the maximum period of overlap of 

the two records. For other data types the two variables 

must have the same number of data points. This produces 

a plot of the cross-correlation as a function of the lag in 

units selected by the user. 

 

4) User: calls the function user_stats.m, in which the user can implement their own analysis methods 

and display results in the UI or add output to the project Catalogue. Currently implements an 

analysis of clusters as detailed for Timeseries data below. 

 

 

Taylor tab 
The Taylor tab allows the user to create a Taylor Plot using 1D or 2D data (e.g timeseries or grids): 

A Reference dataset and a Test dataset are selected. Datasets need to be the same length if 1D, or same 

size if 2D. If the data are timeseries they are clipped to a time-period that is common to both, or any 

user defined interval that lies within this clipped period. The statistics (mean, standard deviation, 

correlation coefficient and centred root mean square error) are computed, normalized using the 

reference standard deviation and plotted on a polar Taylor diagram (Taylor, 2001).  

[The ModelSkill App provides additional tools to test data and the ModelSkill App manual provides 

further details of the methods used.] 
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Selecting New generates a new Taylor Plot. Selecting the Add button adds the current selection to an 

existing plot and the Delete button deletes the current selection. The Clear button resets the UI to a 

blank selection.  

Once New or Add are selected, the user is asked 

whether they want to plot the skill score (Yes/No). If 

Yes, then the user is prompted to set the skill score 

parameters.  As further points are added to the plot, 

this selection remains unchanged (i.e. the skill score 

is or is not included). To reset the option it is 

necessary to close and reopen the Statistics UI.  

If the number of points in the Reference and Test 

datasets are not the same the user is prompted to 

select which of the two to use for interpolation.     

 

 

 

This is the maximum achievable correlation (see Taylor (2001) for 

discussion of how this is used). 

Exponent used in computing the skill score. 

Number of points (+/-W) used to define a local window around the ith 

point. If W=0 (default) the local skill score is not computed. 

Local skill score is computed for window around every grid cell (=1), 

or computes score for all non-overlapping windows (=0) 

Window definition to sub-sample grid for the computation of the 

average local skill score. Format is [xMin, xMax, yMin, yMax]. 

 

(a) time series skill score plot 

 

(b) grid skill score plot 

 

 



 
 CSTmodel manual 

May 2024 

 

 

13 

 

The Taylor Plot shows the Reference point as a green cross and the Test points as coloured circles. 

The legend details the summary statistics and the Case List button generate a table figure listing all the 

results. These can be copied to the clipboard. 

 Taylor diagram legend includes: B – bias; E’’ – 

normalised RMS difference 

The normalised standard deviation and correlation 

coefficient are also given in the Case List table, 

along with the global skill score, Sg, and the 

average local skill score, Sl. 

 

 

3.7  Help 
The help menu provides options to access the App documentation in the MatlabTM Supplemental 

Software documentation, or the App manual. 

 

3.8 Tabs 
To examine what has been set-up the Tabs provide a summary of what is currently defined. Note: the 

tabs update when clicked on using a mouse but values displayed cannot be edited from the Tabs. 

Cases: lists the cases that have been run with a case id and description. Clicking on the first column of 

a row generates a table figure with details of the variables for the case and any associated metadata. 

Buttons on the figure provide access the class definition metadata and any source information (files 

input or models used).  

Inputs: tabulates the system properties that have been set (display only). 

Form: plot the estuary form properties defined for the model and/or imported from a user file. 

X-Plot: displays a plot of the along channel output properties for the selected case (display only). 

XT-Plot: displays a plot of the time varying properties at a selected distance along the estuary. (display 

only). 

Stats: displays a table of results for any analyses that have been run (can be copied to clip board). 

 

3.9 UI Data Selection 
Functions such as Derive Output (3.5), Plotting (3.6.1) and Statistics (3.6.2) use a standardised UI for 

data selection. The Case, Dataset and Variable inputs allow a specific dataset to be selected from drop 

down lists. One each of these has been set to the desired selection the choice is assigned to a button. 

The button varies with application and may be X, Y, Z, or Dependent and Independent, or Reference 

and Sample, etc. Assigning to the button enables further sub-sampling to be defined if required. Where 

an application requires a specific number of dimensions (e.g., a 2D plot), then selections that are not 

already vectors will need to be subsampled. At the same time, the range of a selected variable can be 
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adjusted so that a contiguous window within the full record can be extracted. In most applications, any 

scaling that can be applied to the variable (e.g., linear, log, relative, scaled, normalised, differences) is 

also selected on this UI. The selection is defined in two steps: 

 

Step 1.  

Select the attribute to use. This can be the variable 

or any of its associated dimensions, which are 

listed in the drop-down list. 

The range for the selection can be adjusted by 

editing the text box or using the Edit (Ed) button. 

Any scaling to be applied is selected from the 

drop-down list. 

Press Select to go to the next step or Close to quit. 

 

The number of variables listed on the UI depends on the dimensions of the selected variable. For each 

one Select the attribute to use and the range to be applied.  

Step 2 - Variable only has 

dimension of time. 

 

No selection to be made. 

Edit range if required. 

 

 

 

Step 2 - Variable has 3 dimensions but only 

2 are needed for the intended use. 

 

Select the 1st variable to use as a dimension. 

Edit range if required. 

 

Select the 2nd variable to use as a dimension. 

Edit range if required. 

Use the slider or the Edit (Ed) button to set 

the value of the dimension to use. (A value of 

t=500 is selected in the example shown). 

Press Select to accept the selection made. 

[NB: Only unused dimensions can be selected from the Select drop-down lists. To adjust from the 

default list this can sometimes require that the second Select list-box is set first to allow the first Select 

list-box to be set to the desired value.] 

The resulting selection is then detailed in full (including the ranges or values to be applied to all 

dimensions) in the text box alongside the button being defined. 
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Note where a variable is being selected as one property and a dimension as a second property, any 

sub-selection of range must be consistent in the two selections. This is done to allow variables and 

dimensions to be used as flexibly as possible.  

 

3.10 Accessing data from the Command Window 
In addition to the options to save or export data provided by the Project>Cases>Save and 

Project>Import/Export options, data can also be accessed directly for use in MatlabTM, or to copy to 

other software packages. This requires use of the Command Window in MatlabTM, and a handle to the 

App being used. To get a handle, open the App from the Command Window as follows: 

>> myapp = <AppName>;   e.g., >> as = Asmita; 

Simply typing: 

>> myapp 

Which displays the results shown in the left column below with an explanation of each data type in the 

right hand column. 

 

 

myapp =  

  <AppName> with properties: 

 

Purpose 

       Inputs:        [1×1 struct] A struct with field names that match all the model parameter input 

fields currently  

        Cases:       [1×1 muiCatalogue] muuiCatalogue class with properties DataSets and Catalogue. The 

former holds the data the latter the details of the currently held 

records. 

        Info:         [1×1 muiProject] muiProject class with current project information such as file and 

path name. 

       Constants: [1×1 muiConstants] muiConstants class with generic model properties (e.g. gravity, etc). 

 

To access current model settings, use the following: 

>> myapp.Inputs.<InputClassName> 

To access the listing of current data sets, use: 

>> cs.Cases.Catalogue 

To access imported or model data sets, use: 

>> cs.Cases.DataSets.<DataClassName> 

If there are more than one instance of the model output, it is necessary to specify an index. This then 

provides access to all the properties held by that data set. Two of these may be of particular interest, 

RunParam and Data. The former holds the input parameters used for that specific model run. 

RunParam is a struct with fields that are the class names required to run the model (similar to Inputs 

above). The Data property is a model specific stuct with field names defined in the code for the model 

class. If there is only a single table assigned this will be given the field name of ‘Dataset’. To access 

the dstable created by the model, use: 

>> cs.Cases.DataSets.<DataClassName>(idx).Data.Dataset 

>> cs.Cases.DataSets.<DataClassName>(idx).Data.<ModelSpecificName> 

To access the underlying table, use: 
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>> cs.Cases.DataSets.<DataClassName>(idx).Data.Dataset.DataTable 

The result can be assigned to new variables as required. Note that when assigning dstables it may be 

necessary to explicitly use the copy command to avoid creating a handle to the existing instance and 

potentially corrupting the existing data. 
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4 Supporting Information 
4.1 Basis of the model 
The model adopted is the solution proposed by Cai, Savenije and Toffolon, which is well suited and 

has already been applied to several estuaries (Cai, 2014). The model accounts for the influence of river 

discharge on tidal wave propagation and the along channel variation of mean water level. The 

analytical solutions are obtained by solving a set of four implicit equations, i.e. phase lag equation, 

scaling equation, celerity equation, and damping equation, derived from the conventional 1-

dimensional conservation of mass and momentum equations (Savenije, 2012). In addition, the 

resultant residual water level, due to nonlinear friction, has been considered by adopting an iterative 

procedure. The model reproduces the main tidal dynamics (i.e., tidal amplitude, velocity amplitude, 

wave celerity, and phase lag between elevation and velocity) along the estuary axis. This is referred to 

here as the CST model. For a full description of the model, readers can refer to Cai et al. (2014) and 

related papers (Cai, 2014; Cai et al., 2012a; Cai and Savenije, 2013; Cai et al., 2016; Cai et al., 2012b; 

Cai et al., 2013). An application with a comparison to a more detailed numerical model is provided by 

Zhang et al (2016). 

4.2 Model outputs 
Each model run is saved as a Case and listed on the Cases tab. The results can be exported to an Excel 

spreadsheet along with the model settings using the Project>Scenarios>Save option. The output 

includes 3 datasets for (i) tidal cycle hydraulic properties; (ii) along-channel hydraulic properties; and 

(iii) a table for along-channel form properties that can also be used as an input to the CSTmodel. 

The CST model computes along channel values. Tidal cycle values are then derived assuming a 

symmetric sinusoidal tide. River velocities take account of the variation in cross-sectional area as a 

function of tidal elevation. Stokes drift is estimated iteratively from the tidal velocity over the tidal 

cycle (ut0= utt+ust; and ust = utt2/c; where c=sqrt(g.d)). 

Data that is imported define elevations to a local datum and total velocities. These are decomposed to 

give elevations relative to MTL, and tidal, river and Stokes velocities. The river velocity is estimated 

from the river discharge at the upstream boundary and the imported  CSA (i.e., urx = Qr0/Amtl). This 

generally compares well with the mean of the total velocity (i.e., the residual) over a tidal cycle. 

However, the former may have spikes and these can be reduced by using an effective CSA, obtained 

by adjusting the imported CSA to reproduce the residual velocities (i.e., Aeff = Qr0/urx). The along-

channel values are then scaled based on the variation in the CSA over a tidal cycle. These are 

subtracted from the total velocities to give an initial estimate of the tidal velocities, which are then 

adjusted to separate out the Stokes velocity (as used in the CST model).  

(i) Tidal cycle hydraulic properties 

Variable Units Description 

Elevation m Water elevation (x-t): Model = symmetric tide from tidal elevation 

amplitude and along channel phase using cosine function); Imported 

= elevation data minus the mean tide level. 

TidalVel(*) m/s Tidal velocity (x-t): Model = symmetric tide from tidal velocity 

amplitude and along channel phase using sine function); Imported = 

decomposed estimates from total velocity input and river discharge. 

RiverVel m/s River velocity (x-t): Model = along channel value adjusted to 

account for variations in CSA; Imported = river discharge divided by 

the time -varying CSA. Option to adjust the CSA to an effective 

value using the mean of the total velocity (i.e., the residual) over a 

tidal cycle. 
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StokesVel m/s Stokes drift velocity (x-t): estimated iteratively from the tidal 

velocity over the tidal cycle (ut0= utt+ust; and ust = utt2/c; where 

c=sqrt(g.d)) in both cases. 

(*) – imported data defines Elevation and Total velocity as a function of x-t. This is then decomposed to match the 

CSTmodel output with the 3 components. 

(ii) Along-channel hydraulic properties (derived from (i) for both CST model and imported data) 

Variable Units Description 

MeanTideLevel mAD Mean water level (mAD) – mean of elevations over a tidal cycle 

TidalElevAmp m Elevation amplitude (m) – Model = obtained by integrating the 

damping number; Imported = average of maximum and minimum 

water level magnitudes over a tidal cycle. 

LWHWratio - LW/HW ratio (-) – Model = 1; Imported = magnitude of 

minimum/magnitude of maximum water levels over a tidal cycle. 

TidalVelAmp m/s Velocity amplitude (m/s) – numerical integration over tidal cycle 

RiverVel m/s Velocity (m/s) – numerical integration over tidal cycle 

Optional additional output 

StokesDrift m Stokes drift velocity (m/s) – numerical integration over tidal cycle 

PhaseAngle rad Lag of velocity relative to elevation – obtained using cross-

correlation (option in code to use time between peaks). This is 

equivalent to ratio of csa convergence length to tidal wavelength,  A 

= LA. 

InterSlope 1:m Slope of intertidal as given by intertidal width divided by tidal 

amplitude assuming two shores (i.e., Wint/4/a). 

effHydCSA m2 Effective hydraulic CSA –  river discharge divided by along-channel 

river velocity estimated from residual of total velocity; i.e., Aeff = 

Qr0/urx. 

 

(iii) Along-channel form properties (imported datasets or derived from input parameters) 

Variable Units Description 

Amtl m2 Area at mean tide level (exponential if modelled) 

Hmtl m Hydraulic depth at mean tide level (exponential if modelled) 

Whw m Width at high water (exponential if modelled) 

Wlw m Width at low water (exponential if modelled) 

N - Manning’s N (specified over reaches if modelled) 

 

4.3 Derive Output 
The Run> Derive Output option allows the user to make use of the data held within App to derive 

other outputs or, pass selected data to an external function (see Section 3.5). The equation box can 

accept t, x, y, z in upper or lower case. Time can be assigned to X, Y, or Z buttons, or simply included 

in the equation as t (as long as the data being used in one of the variables includes a time dimension). 

Each data set is sampled for the defined data range. If the data set being sampled includes NaNs, the 

default is for these to be included (button to right of Variable is set to ‘+N’). To exclude NaNs press 

the button so that it displays ‘-N’. The selection is based on the variable limits defined whenever a 

variable is assigned to X, Y or Z using the X, Y, Z buttons. 
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The equation string entered in the UI is used to construct an anonymous function as follows: 

heq = str2func(['@(t,x,y,z,mobj) ',inp.eqn]); %handle to anonymous function 
 

[varout{:}] = heq(t,x,y,z,mobj); 
 

or when using dstables: 

heq = str2func(['@(dst,mobj) ',inp.eqn]);     %handle to anonymous function 
 

[varout{:}] = heq(dst,mobj); 
 
 

This function is then evaluated with the defined variables for t, x, y, and z and optionally mobj, where 

mobj passes the handle for the main UI to the function. Some functions may alter the length of the 

input variables (x, y, z, t), or return more than one variable. In addition, the variables selected can be 

sub-sampled when each variable is assigned to the X, Y, or Z buttons. The dimensions of the vector or 

array with these adjustments applied need to be dimensionally correct for the function being called. 

This may influence how the output can be saved (see Section 4.3.2). 

If the function returns a single valued answer, this is displayed in a message box, otherwise it is saved, 

either by adding to an existing dataset, or creating a new one (see Section 4.3.2).  

NB1: functions are forced to lower case (to be consistent with all Matlab functions), so any external 

user defined function call must be named in lower case. 
 

Equations can use functions such as diff(x) - difference between adjacent values - but the result is n-1 

in length and may need to be padded, if it is to be added to an existing data set. This can be done by 

adding a NaN at the beginning or the end:  

e.g.: [NaN;diff(x)] 

NB: the separator needs to be a semi-colon to ensure the correct vector concatenation. Putting the NaN 

before the equation means that the difference over the first interval is assigned to a record at the end of 

the interval. If the NaN is put after the function, then the assignment would be to the records at the 

start of each interval.  
 

Another useful built-in function allows arrays to be sub-sampled. This requires the array, z, to be 

multiplied by an array of the same size. By including the dimensions in a unitary matrix, the range of 

each variable can be defined. For a 2D array that varies in time one way of doing this is: 

>> [z.*repmat(1, length(t), length(x), length(y))] 

NB2: the order of the dimensions t, x, y must match the dimensions of the array, z. 
 

NB3: When using Matlab compound expressions, such as the above sub-sampling expression, the 

expression must be enclosed in square brackets to distinguish it from a function call. 

 

Adding the comment %time or %rows, allows the the row dimension to be added to the new dataset. 

For example if x and y data sets are timeseries, then a MatlabTM expresion, or function call, can be 

used to create a new time series as follows: 

x^2+y  %time 

 

4.3.1 Calling an external function 
The Derive Output UI can also be used as an interface to user functions that are available on the 

Matlab search path. Simply type the function call with the appropriate variable assignment and the 
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new variable is created. (NB: the UI adopts the Matlab convention that all functions are lower case). 

Some examples of functions provided in CSTmodel are detailed in Section 4.3.3.  

The input variables for the function must match the syntax used for the call from the Derive Output 

UI, as explained above. In addition, functions can return a single value, one or more vectors or arrays, 

or a dstable (see Section 4.3.2). If the variables have a dimension (e.g., time) then this should be the 

first variable, with other variables following. If there is a need to handle additional dimensions then 

use the option to return a dstable. 

If there is no output to be passed back, the function should return a variable containing the string 'no 

output' to suppress the message box, which is used for single value outputs (numerical or text). 

An alternative when calling external functions is to pass the selected variables as dstables, thereby also 

passing all the associated metadata and RowNames for each dataset selected. For this option up to 3 

variables can be selected and assigned to the X, Y, Z buttons but they are defined in the call using dst, 

for example: 

[time,varout] = myfunction(dst, 'usertext', mobj); 
 
dst = myfunction(dst, 'usertext’, mobj); 

 

where ‘usertext’ and mobj are call strings and a handle to the model, respectively. 

This passes the selected variables as a struct array of dstables to the function. Using this syntax, the 

function can return a dstable or struct of dstables, or as variables, containing one or more data sets. 

 

4.3.2 Input and output format for external functions 
There are several possible use cases: 

 

4.3.2.1 Null return 
When using a function that generates a table, plots a figure, or some other stand alone operation, 

where the function does not return data to the main UI, the function should have a single output 

variable. The output variable can be assigned a text string, or ‘no output’, if no user message is 

required, e.g.: 

function res = phaseplot(x,y,t,labels) 
… 
res = {'Plot completed'}; %or res = {‘no output’}; for silent mode  

… 
end 

 

4.3.2.2 Single value output 
For a function that may in some instances return a single value this should be the first variable being 

returned and can be numeric or text, e.g.: 

function [qtime,qdrift] = littoraldriftstats(qs,tdt,varargin) 

… 
%Case 1 – return time and drift 

qdtime = array1; 
qdrift = array2; 
%Case 2 – return summary value 

qtime = mean(array2); %return single value 
%Case 3 – return summary text 

qtime = sprintf('Mean drift = %.1f',mean(array2)); %return test string 
… 
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end 

 

 

4.3.2.3 Using variables 
If only one variable is returned (length>1), or the first variable is empty and is followed by one or 

more variables, the user is prompted add the variables to: 

i) Input Cases – one of the datasets used in the function call; 

ii) New Case – use output to define a new dataset; 

iii) Existing Case – add the output to an existing dataset (data sets for the selected existing 

case and the data being added must have the same number of rows. 

In each case the user is prompted to define the properties for each of the variables.  

Note that variable names and descriptions must be unique within any one dataset. 

 

function y = moving(x,m,fun) 
%a single variable is returned with no rows  

 y is a vector or array 

… 
end 

 

or  

function [x,y,z] = afunction(x,m,fun) 
%multiple variables returned but the first variable is empty  

 x = [ ]; 

y and z are a vectors or arrays 

… 
end 

 

When the first variable defines the rows of a table and subsequent variables the table entries, all 

variables must be the same length for the first dimension. This is treated as a new Case and the user is 

prompted to define the properties for each of the variables. 

function [trange,range,hwl,lwl] = tidalrange(wl,t,issave,isplot) 
%first variable is row dimension followed by additional variables  

 trange,range,hwl,lwl are vectors or arrays 

… 
end 

 

4.3.2.4 Using dstables 
When the output has multiple variables of a defined type it can be more convenient to define the 

dsproperties within the function and return the data in a dstable. This avoids the need for the user to 

manually input the meta-data properties. In addition, if the function generates multiple dstables, these 

can be returned as a struct, where the struct fieldnames define the Dataset name. 

function dst = tidalrange(wl,t,issave,isplot) 
%dst is a dstable with variables, dimensions and dsproprties assigned  
%as required, or a struct of dstables with the struct fieldnames defining 
%each Dataset. 

 dst = … 

… 
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end 

 

Similarly if the input is also using dstables, the syntax is as follows: 

function dst_out = myfunction3(dst_in,'usertext',mobj) 
%dst_in is one or more input dstables, ‘usertext’ is some additional 
%instruction to the function and mobj is a handle to the model  
%allowing access to other datasets. dst_out is either a dstable, or a  
%struct of dstables with the struct fieldnames defining each Dataset. 

 dst = … 

… 
end 

 

Adding functions to the Function library 

To simplify accessing and using a range of functions that are commonly used in an application, the 

function syntax can be predefined in the file functionlibrarylist.m which can be found in the utils 

folder of the muitoolbox.  This defines a struct for library entries that contain: 

• fname - cell array of function call syntax; 

• fvars - cell array describing the input variables for each function; 

• fdesc - cell array with a short description of each function. 

 

New functions can be added by simply editing the struct in functionlibrarylist.m, noting that the cell 

array of each field in the struct must contain an entry for the function being added. In addition, a sub-

selection of the list can be associated with a given App based on the class name of the main UI. To 

amend the selection included with an App or to add a selection for a new App edit the ‘switch 

classname’ statement towards the end of the function. 

The Function button on the Derive Output UI is used to access the list, select a function and add the 

syntax to the function input box, where it can be edited to suit the variable assignment to the XYZ 

buttons.  

4.3.3 Pre-defined functions 
The following examples are provided within CSTmodel, where the entry in the UI text box is given in 

Courier font and X, Y, Z, refer to the button assignments. 

Some useful examples include:  

1. Moving Average. There are several moving average functions available from the Matlab 

Exchange Forum, such as moving.m. The call to this function is:   

moving(X, n, 'func') ,  where x is the variable to be used, n specifies the number of points to 

average over and ‘func’ is the statistical function to use (e.g. mean, std, etc). If omitted the mean is 

used. Add %time to the call, to include time in the output dataset. 

2. Moving average (or similar) of timeseries, over defined duration, advancing at defined interval 

movingtime(x, t, tdur, tstep, 'func'), where x is the variable to be used and t the 

associated datetimes (defined by variable selection), tdur is the duration over which to apply the 

statistic, tstep is the interval to advance the start time for the averaging period and ‘func’ is the 

statistical function to use (e.g. mean, std, etc). If omitted the mean is used. tdur and tstep are both 

duration character strings of form ‘2.5 d’. Any of the following duration intervals ca be used:  y, d, 

h, m, or s. Returns a time series based on the defined tstep, where the time used is for the 

beginning of each stepping interval, i.e. every tstep from the start of the record to the nearest 

interval that is less than tdur from the end of the record. 



 
 CSTmodel manual 

May 2024 

 

 

23 

 

3. Recursive plot. Generates a plot of a variable plotted against itself with an offset (e.g. x(i) versus 

x(i+1) ). This is called from the Derive Output GUI using: 

recursive_plot(x, ’varname’, nint), where x is the variable, ‘varname’ is a text string 

in single quotes and nint is an integer value that defines the size of the offset.  

4. Phase plot. This function is similar to the recursive plot function but generates a plot based on two 

variables that can, optionally, be functions of time. The call to this function is:  

phaseplot(X, Y , t), where X and Y are the variables assigned to the respective buttons and 

t is time (this does not need to be assigned to a button and  t can be omitted if a time stamp for the 

datapoints is not required). 
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5 Input file formats 
All input functions use ASCII text files. 

5.1 Along-channel Model Input Properties 
Properties to define the along-channel variation in cross-sectional area and width are loaded using 

Setup>Estuary Properties with a file that 1 header line and 4 or 5 columns (including the Manning 

coefficient is optional).  The columns are: x - Distance from mouth,  Amtl - Area at mean tide level, 

Hmtl - Hydraulic depth at mean tide level, Whw - Width at high water, Wlw - Width at low water, 

Manning_N - Mannings N (optional). 

 

 

  



 
 CSTmodel manual 

May 2024 

 

 

25 

 

5.2 Velocity and Elevation Observations 
The format for the Elevation and Velocity files are loaded using Setup>Import Data>Load menu 

option when loading the Along-channel properties. The files have a 1 line header, 1 column for time, 

and N columns for elevation or velocity at each time interval, where N is the number of distances 

included in the along-channel properties file (see above) and in the same order (increasing or 

decreasing). An example of the first 1.5 hours at 0.25-hour intervals is shown below where there are 

32 columns (text is wrapped to fit in display window). 

Input water level Elevations should be relative to the local datum and include any along channel 

changes in mean water level. These are used to compute the along channel mean tide level (mtl) and 

remove this from the imported elevations to give the elevations relative to mtl (comparable with the 

values computed by the CSTmodel). The imported Velocity values are assumed to be total velocity. 

These are decomposed to tidal, river and Stoke’s velocities, again to be compatible with the 

CSTmodel output. 
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6 User functions 
To allow the user to add plotting or statistical routines, without disrupting the underlying model 

structure, selected functions have been made external to the class definitions. Copies of the sample 

files can be found in the ..\muitoolbox\muitemplates folder. For User Data and User Model these can 

be copied to a working folder and renamed to suit the application. For User Statistics and User Plots 

the files in the templates folder can be used to replace the version in the ..\muitoolbox\psfunctions 

folder.  The user_plots and user_stats functions are called from the respective UIs, hence the names 

should not be changed (unless the code in calling class is also edited). 

 

6.1 User Data 
This option allows the user to easily load data that is different to the formats provided. The class is 

muiUserData and the class file handles the loading and amending of records but requires the file 

format and meta-data for the variables being loaded to be defined. The file 

dataimport_format_template.m, in the ..\muitoolbox\muitemplates folder, provides an example of the 

code needed to load a bespoke file format. This is called from Setup> Import data> User Data and 

loads the date into the generic muitoolbox muiUserData class. The key functions that need to be edited 

in the file are getData and setDSproperties. The getData function defines how to read the data and 

assign it to a single dstable or a named struct array of dstables, where each field name provides a 

reference to the dataset in the table. The setDSproperties function defines the metadata needed to 

describe the variable and any associated dimensions. Examples of the code to load a range of different 

formats can be found in the ...\muiAppCoastalClasses\FormatFiles folder. 

 

6.2 User Statistics 
On the General and Timeseries tabs of the Statistics UI there is a Statistic list dialogue box. The User 

option in this list calls the user_stats.m function, which can be found in the ..\muitoolbox\psfunctions 

folder. This allows the user to define their own workflow, accessing data and functions already 

provided by the EnergyFlux  App. The sample code illustrates the workflow for timeseries data to 

produce a clusters plot. If called from the General statistics tab the code simply returns a warning 

message. The code could be added to provide some alternative function when called from the General 

stats. 

 

6.3 User Plots 
On the Plots UI there is a Plot type list dialogue box. Select User and assign the required variables to 

the buttons for the selected tab. This passes the variables selected to the user_plot.m function, which 

can be found in the ..\muitoolbox\psfunctions folder.  This allows the user to set up their own plotting 

function. The demonstration function provided plots a line or surface plot depending on whether a 

variable has been assigned to  the z-dimension. 
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7 Program Structure 
The overall structure of the code is illustrated schematically in Figure 1. This is implemented through 

several classes that handle the graphical user interface and program workflows (Main UI) and several 

classes that handle the data manipulation and plotting (Input UIs and Data UIs).  

Figure 1 - – High level schematic of program structure 

 

The interfaces and default functionality are implemented in the CSTmodel App using the following 

muitoolbox classes depicted in Figure 2, which shows a more detailed schematic of the program 

structure. See the muitoolbox and dstoolbox documentation for more details. 

Figure 2 – schematic of program structure showing how the main classes from muittoolbox and dstoolbox are used 

 

In addition, the CSTmodel App uses the following classes and functions: 

CSTparameters – class to handle input for model parameters 

CSTrunparams – class to handle input for model run time parameters 

CSTformprops – class to load estuary form properties from a text file 

CSTrunmodel – class to handle call to model, tab plot and output definition 
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CSTdataimport – class to handle import of observed data or numerical model output to compare with 

CST model output. 

cst_dataformat – functions to define format and handling for data import.  

cst_x_plot – plot along channel variations on a tab or figure. 

cst_xt_plot – plot variations in time or distance on a tab or figure. 

cstmodel_update –  update saved models to newer versions of CSTmodel. 

cst_phaselag – compute lag between elevation and velocity. 

cst_decompose_velocity – decompose imported velocity into tidal, river and Stokes velocities and 

compute additional parameters for comparison with CSTmodel output. 

cstmodel_update –  update saved models to newer versions of CSTmodel. 

cst_model – CST model code, provided by Cai HuaYang wit the following functions: 

f_new_2012 – analytical solution for tidal dynamics proposed by Cai, H., H. H. G. Savenije, and M. 

Toffolon, 2012, Journal of Geophysical Research, 117, C09023 

f_toffolon_2011 – analytical solution for tidal dynamics proposed by Toffolon, M., and H. H. G. 

Savenije (2011), J Geophys Res-Oceans, 116, 

findzero_new_discharge_river – analytical solution dimensionless parameters for river flow 

findzero_new_discharge_tide – analytical solution dimensionless parameters for tide 

newtonm – Newton Rapshon root finder 
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